How to set resolution

I am running the Rocky-8.3-RC1. I guess everybody is right?

Anyway, I have a Windows 10 laptop running Oracle VBox, but without Guest Additions installed.

My physical laptop can handle a resolution up to “1920 x 1080”. So, I alter the VM’s resolution to match - “1920 x 1080”. I log out of the user, and then log back in to test and determine if the resolution setting remained intact.

Is the RC1 not ready for such changes, or am I making the change for a persistent setting incorrectly?

Thanks,
Warron

have you tried installing the guest additions?

1 Like

Hi @jorp, since posting my question last night (I ran out of time before going to bed), I have installed VBox Guest Additions - yes.

With the VBox Guest Additions installed though I am still experiencing no success with being able to set the VM’s resolution greater than “800x600,” which still has me baffled.

Full disclosure, I am also on the ALMALinux forums and I am having even less success on ALMALinux, wherein I cannot even get VBox Guest Additions to even install successfully.

I don’t have much experience VBox honestly, so I’m not sure how much more of a help I could be. Where are you check resolution options exactly? Within the OS in the GUI, or via VBox?

Hi, thanks for the quick reply.

I checked the resolution options within the OS of the RockyLinux VM. I right-click the background of the GUI and select “Display Settings” from the context menu.

All I could really recommend is maybe checking out this for some info. I haven’t seen anyone report this issue with VBox just yet.

@jorp thanks for the link. That surprises me, but it I will check and see if I am using an incorrect VBox configuration for the video configuration. That is possible.

I’ve installed Rocky Linux RC1 with VBox Support and XFCE desktop.

But, I have to set up in Display settings of XFCE or use xrandr to resize the screen.

@jorp you were on to somerhing! Good call!

I went into my VBox settings and altered the “Display Adapter” from VMSVGA (silly on my part) to VBOXSVGA and that enabled me to alter and save the configuration settings for the resolution.

Then, what confused me a little, I went back and altered the Display Adapter settings back to VMSVGA and it remained on the high resolution for a single reboot, but after that the Gnome Logon page never actually presented itself again. It was weird.

So I eventually was forced to set the Display Adapter specifically and only on “VMSVGA” and the Gnome Logon page displayed properly again.

1 Like

Maybe would be some tricks Virtualbox… ¯\_(ツ)_/¯