Display resolution won't 'stick'

Running Rocky as VMware guest. Installation was smooth. Host has 1680x1050 display. Each time I run Rocky it opens at 1280x768 despite having changed it under Settings in the previous session. I’ve run heaps of different guests over the years and never had this problem. How can I make the host resolution stick?

I’m currently trying out the recommendation located here for my Virtual Box install…

Maybe it might work for you?

Unfortunately it didn’t work, but thanks for your effort :slight_smile:

I did this a different way, and this worked for me. Similar to the original poster I decided to set mine to 1680x960. Then I ran this command:

[root@rocky ian]# for p in /sys/class/drm/*/status; do con=${p%/status}; echo -n "${con#*/card?-}: "; cat $p; done

It listed:

Virtual-1: connected

so Virtual-1 is my display. There are others, the important one is the connected one. Then I edited /etc/default/grub and added the following line:


I found grub.cfg in /boot/efi/EFI/rocky on my system, and then ran:

grub2-mkconfig > /boot/efi/EFI/rocky/grub.cfg

Maybe on some systems it could be under /boot/grub2/grub.cfg - just have to check what it is on your system. After rebooting, my system now worked fine with the resolution remembered each time.

1 Like

This seems to have done the trick for me!

How did you come to this finding?

A bit on the belated side - but I also found this article…

@Priest_Apostate I used to use that vga= stuff to set my text consoles on some servers or machines that would default to a really basic resolution. Cannot remember if that helped for the graphics resolution though.

The info I found above was related to Wayland since Xorg is not being used. I dug through a few articles and whilst they were for other distros the concept is pretty much the same for any distro when using Wayland. This is why anyone who has used xrandr for gaining access to other resolutions will find xrandr no longer helps with Wayland. Hence this method.

As a shortcut for editing the grub config, you can one-line it with grubby (installed by default in most configs) like sudo grubby --update-kernel=all --args=“video=Virtual-1:1680x960@60”


Found it under /boot/grub2/grub.cfg but alas, still no joy :frowning:
(that is, under VMWare Workstation 16) I haven’t tried it with VirtualBox and probably won’t - it’s not my ‘virtualiser of choice’ and getting Rocky running was only, at this stage, a curiosity not an essential. Thanks for all the suggestions: I’ll keep them and perhaps try again another day :slight_smile: If the discussion has helped others to a successful conclusion then it hasn’t all been a loss.

I used mine on VMware ESXi, along with vcenter. Theoretically should be the same for VMware Workstation, although perhaps there are some variations maybe? Sadly I don’t have access to VMware Workstation so am unable to check/test find a solution for you. Maybe there are some other options you can check in the VM configuration relating to scaling the display/video, etc - maybe it’s disabled and potentially causing an issue. I’ve seen references to this, before I started my testing with the solution that worked for me.

Make sure open-vm-tools is installed just in case. I mostly use KVM as my virtualisation with qemu-guest-agent installed, so potentially missing VMware tools or ability to scale the screen is an issue.

Hmmm… Now there’s an idea :slight_smile: It’s a while since I played with KVM. I’ll see how that goes over the next few days. Thanks :slight_smile:

1 Like

@foxinsocks BTW, it’s enough in KVM to just login, go into settings, and set screen resolution. Now the first reboot it didn’t work, the second when I applied it and then rebooted it did work and remembered for me 1920x1080. Not sure why I needed to do it twice. Subsequent reboots were fine though. GDM login screen still shows as 1024x768 but this isn’t a problem for me. After login it changes the resolution.

Mine was a minimal install of Rocky, and then just doing:

dnf groupinstall "Server with GUI"
systemctl set-default graphical

I didn’t need to do any of the stuff with grub like with VMware. So it’s definitely a hypervisor (VMware) specific problem.

Thanks :slight_smile: Stayed up a bit later and tried KVM - before your ‘after-thought’. Initially, the mod to grub.cfg did nothing, then your ‘after-thought’ came. In KVM I did View > Scale Display > Only when Full Screen and ticked Auto resize VM with window.
Success :slight_smile:
Not sure why this is a VMWare problem since every other OS - and there have been many :slight_smile: - in the past has performed as expected.

1 Like

I was/am using a CentOS 8-migrated-to-Rocky VM in Virtualbox for this setup.

Thanks for mentioning Wayland - I was curious as to why were my X11, and xrandr attempts not working.

This article seems to explain the services for someone like me (I barely know my way around, and I’m learning how to become a danger to myself)…

I am a touch confused, though: what is the “display server,” and what is the client? As both are residing upon the same system, wouldn’t they be one and the same?

The client is you who connected to the display server to run your apps which in the article are mentioned as client apps.

You can connect remotely to another display server. For example I can enable xdmcp on a server and then from my Linux laptop across the network connect to it. Whilst in most cases you are interacting locally it doesn’t have to be that way.

Enabling xdmcp isn’t quite the same as rdp or other remote desktop protocols but I guess could be considered as such.

1 Like