Fix full screen problem in VirtualBox Rockylinux

Hi, I installed the Rocky Linux operating system in the virtual box, but I can not activate the auto-resizing option.
All the work I needed is for a few weeks. I’ve been tested on several Host systems (Windows - Ubuntu - Linux Mint).
But i can’t fix the problem
May I guide me

Hi @reza0,

First: Welcome to the forum and thanks for taking the time to seek support.

Now, I’m not sure if I understand correctly.
Are you talking about the auto-resizing of the HOST window or is it the auto-resizing of the GUEST display inside tho host’s window? In any case, have you installed the guest additions inside the RockyLinux VM ? And what is your host’s operating system?

Cheers, Thomas

I mean, this part is not clear
All required packages are installed


the option appears to be already activated. But I guess it is disabled and simply doesn’t work because VBox is either missing kernel drivers on the host operating system and/or the guest additions ISO file in the guest session (that needs to be downloaded as ISO and mounted from within the VM).

To verify:

  1. Is any kind of screen resolution enabled in above menu, submenu “Virtual Screen 1” or are they all greyed-out (disabled) ?
  2. Have you mounted the guest additions inside the VM?
  3. What are the VM settings for “graphics” - can you post a screenshot?

Cheers, Thomas

1 Like

The rest of the options are on and only this is off
Requirements are also installed

Graphic settings

Oh, interesting that you cannot pick a different graphics controller.

I just noticed that my VirtualBox (rocky being the host here!) has the same issue: I cannot use auto-resize either! On that occasion, I went through installs of packages, changing VBox graphics driver, kernel stuff, sudo’ing the VBox client and what not… there are plenty of ways on the internet about how to fix or workaround this issue.

None of them works for me.

And this one here makes me wonder whether it isn’t still broken perhaps:

It seems like a glitch at some point where kernels, drivers and access rights come together.
Sorry I didn’t notice that before, I usually set the host to a certain fixed resolution and I remember that I last used the auto-scaling some months (years?) ago in a 5.x version of VBox.

Sorry, I’m lost here.
This might need someone with more Linux tech skills than me.

RHEL (and hence Rocky) includes libvirtd/KVM hypervisor. VirtualBox is a third-party hypervisor?
(If host is Windows, Ubuntu, or Mint, then “native hypervisor” might be different.)

Could it be that VirtualBox supports Xorg, and Rocky is using Wayland maybe and so the options in Virtualbox don’t work because of that?

1 Like

I installed this package and restarted the host. The Virtual box problem was solved .
sudo apt install virtualbox-guest-x11
Thank you very much for your tips :pray:


Hi @iwalker ,

that’s appears to point into the right direction, albeit that it’s not 100% apllicable in my situation because I’m running X11 instead of (the default) wayland.
But from what @reza0 wrote, it definitely has to do with X11. I wonder why this isn’t documented anywhere with VritualBox. Or simply why that package isn’t fetched during install on a system running X11. Hmm.

Anyways. From what I understand from reza’s latest post, it indeed was a host-related issue and that host was not RockyLinux. In other words, it has nothing to do with RockyLinux itself. And that was one of the points I still wasn’t able to clarify with them: What is the host OS? Okay, now we know.

That still doesn’t solve my flavour of the issue with RL being the host. But it’s not that crucial to me, since I rarely use VMs and I’m fine with the static screen size I configured them to.

Cheers, Thomas


I tested it on Ubuntu and Linux Mint hosts, this was a problem, but now it has been fixed