[SOLVED!] Unable to get Gnome Classic for Rocky Linux Green Obsidian

Hello Guys!
I have a Linux home desktop , which I have recently shifted from CentOS 7 to Rocky Linux 8.4 Green Obsidian. I used the minimal installation DVD.
I was previously using Gnome Classic, and I much prefer that interface. In CentOS 7, at the login screen, we had the option of choosing the desktop environment, using a gear icon (before sign-in button) like shown in this link https://i.stack.imgur.com/YIUew.jpg
I am not sure that the one I am asking for -namely the Gnome Classic is in this link above that I have posted.

At the same time, I am seeing that it is probably possible to have it in Rocky Linux like this image here.

However, I am not seeing that gear icon. Can someone please point out what am I doing wrong or how I retrieve it?


Some clarifications are in order.

"I was previously using Gnome Classic " - I meant in CentOS 7.

"However, I am not seeing that gear icon. " - I meant in Rocky 8.4 Green Obsidian

I saw this link by RHEL folks, it discusses the one I want at the bottom. I am pretty sure I want this Gnome Classic Wayland Display Server, like so

I appreciate the fact that I can have multiple windows tiled in this Gnome rendition, as well as the availability of the multiple desktops at the bottom right corner.


Guys, Some help would be very appreciated! I hope I haven’t asked a we-don’t-talk-about-that feature


What Software did you select when installing Rocky?

I can confirm either selecting Server with GUI or Workstation Gnome Application, provides classic gnome for both X11 & wayland.

If you are installing workstation, this kickstart configuration for Anaconda may be of interest:

Started as project for centos 8 / stream, but recently a new ks config (rocky-ks.cfg) has been added.

Thanks Tom.



Off topic now, but I’ve updated the readme with this in mind. I hope its much clearer now.


hi @tjdoyle
Thanks for your reply
I used the workstation one. I’m not aware of the tools I should have added - I had these

I will look up that github thing. But I am not very confident of using it.
Warm regards,

Sorry Tom,
I can’t figure out what is to be done. I am not aware of where to start?
Do I need to create account to use that .cfg file?
Do I need to reinstall Rocky 8.4?
I have only used CentOS from 2013-2018, after which I had to (imagine that) switch over to the abomination that is W10.
Its only last year that i got access back to my centos workstation, but felt that it was time to switch to a modern OS after Rocky 8.4 assured of support till 2029.

Long story short, I never needed to tinker around my CentOS, had nice helpful IT-admins who would play genie, much less used github or other tools to build software, so I am kind of new to this.
Please suggest ways to get around my problem, like you would explain an average 12 year old (added the disclaimer to avoid protests from precocious 12 year-olds).

Come to think of it, your explanation can possibly go into the README.md for the uninitiated whom I represent.
Warm regards,


I can’t see why those selections would prevent gnome classic from being installed. Anyway should be able to install without re-installation. Please try:

dnf install gnome-classic-session

(if using non-root admin, then its sudo dnf install gnome-classic-session)

Sorry the github link requires modifying an install iso, so probably overkill. But if interested, I can provide more info.

Thanks Tom.

Thanks Tom,
Funny it says it’s already there on my system. Quoting the message:
“Package gnome-classic-session-3.32.1-14.el8.1.noarch is already installed.
Dependencies resolved.
Nothing to do.

Then why wouldn’t it show up at the log-in page?


That is an odd one, could you please provide the content of:

ls /usr/share/xsessions/

Thanks Tom.

Here goes:

gnome-classic.desktop gnome-xorg.desktop
gnome-custom-session.desktop xinit-compat.desktop


Could try reinstalling:

dnf reinstall gnome-classic-session

Then restart.

Thanks Tom.

OK, I will do this and reply later, as I am doing something else. its a bit late here and I ought to be sleeping. I will report tomorrow, not now.
Thanks Tom, much appreciated.

1 Like

Hi Tom,
I reinstalled as the root user and rebooted.
No difference - I still am without a choice (no gear icon on login page) to choose the desktop environment from.

I hope we can solve this issue tomorrow - appreciate your help thus far.


Does your login have a password?

I only ask because I believe passwordless login, can cause the cog to not be available.

Thanks Tom.


@nmp could try setting th default session via the commandline:


so nano or vi: /var/lib/AccountsService/users/$USER


@tjdoyle Finally we did it.

  1. To answer your question,
    yes, I did/do have password enabled login

  2. I used cat on /var/lib/AccountsService/user/$user and it took an inordinately long time to display results.

  3. Surprisingly there was no entry for Xsession - at all. I added the whole line. I was expecting it to be having XSession=gnome

  4. There are two more entries in the file apart from what is shown at Configure a user default session.
    After adding the XSession line to the file, cat command yields,

Hope this anomaly (of missing XSession field) can be explained to me - and more importantly if it is serious, can be tackled accordingly.
Thanks again @tjdoyle you have been great help.

1 Like


Odd that it took so long to display, that along with the cog being misisng; could be indicator of deeper problems with your setup. Either software or hardware. I would start with a file system check:

touch /forcefsck

Reboot. More details can be found here: How to Use 'fsck' to Repair File System Errors in Linux

Actually I was expecting an XSession entry, but for it to be blank. I think the system default is set by a config file in /etc.

Anyway I glad to here you can now login in to gnome-classic? Just out if interest is the cog now visible on the login screen?

Thanks Tom.

hello Tom,
Yes, the cog was visible when i had rebooted the system. Interestingly enough, it is not available if I unlock the system after locking it. Perhaps this is expected.

Regarding fsck, maybe I dont understand how mounting works, but top quote the link shared, " n order to run fsck , you will need to ensure that the partition you are going to check is not mounted."

From the looks of your message previous message, you wanted to check the partition on which Rocky is installed. If I unmount this - how will I even run the fsck command? I mean can i unmount the partition on which my OS - only OS in this case is installed?



The command I provided above (you may need to run it with sudo), should force a filesystem check on startup before the OS is mounted:

Thanks Tom.

you mean, this command if issued, will have to be followed by reboot? Or can I continue working and it will perform the check at next reboot after I am done for this session.
I will be away for a while - maybe a couple of hours

thanks and regards


Yeah if you issue the command, next time the machine starts up; it will do the file system check. Doesn’t need to be straight away.

Thanks Tom.