Software Selection not Available

I have downloaded latest Rocky Linux 8.4 DVD.1.iso but looks like struggling to get it install on my dell laptop and software selection is not available. Also option for file is missing and I cannot point my repositories to local media for example /run/install/repo. Soucrce installation repositories are not available.
I tried installation method using proxy using ethernet and over the wifi network but I had to abandon the installation. I tried with Minimal as well but didnt work. I would like to know if anyone has experienced similar issue and if yes how it was resolved?

Any assistance will be highly appreciated.

I have managed to install Rocky on KVM and somehow installation didnt work on my physical device. Rockly ISO image mounted inside KVM and works fine. This is very strange.

I am suspecting this could be related to Installation media used for installation where installation method particular looking for “/dev/sr0” device and unable to locate packages from my usb /dev/sd…

I had the same issue trying to install with the ISO when I tried to do it from a multi-boot scenario.
If you create a bootable USB drive from the ISO using DD it works as expected.
These instructions work if you’ve not done it that way before (I hadn’t)

Thanks Mike for suggestion.
I did try with dd previously but this time it did work. very weird.