Error setting up base repository Rocky 8.4

I’ve issue when install Rocky 8.4 from DVD, I’m installed on vmware it’s success. But I burn USB to install my PC, I seem err “Error setting up base repository”
I don’t what happens. it seems not detect ios from usb.

Im try add url Index of /pub/rocky/8.4/BaseOS/x86_64/os/
But it’s error still. Im decision copy file iso to usb, step Installation Source, i browsers to file iso to setting and worked

what is the file system of the usb if it ntfs then that the cause

format it using fat32 you can use those app to build bootable usb

Rufus - Create bootable USB drives the easy way for windows
Download Fedora Workstation fedora media writer for windows and mac

for linux you can use the disk app and choose restore image

hope that help and have a nice day :slight_smile:

I am having the same issue. I formatted the USB as fat32, and created the usb with the Rufus application.

I have tried setting the specific url instructed here (Installation Source error). I also tried the url of the iso itself. (…\iso\Rocky-8.4-x86_64-dvd1.iso). I have had a second person to verify there are no typos in my url. I also tried using the mirror at .

This is a fresh install on a Dell Poweredge T410. There is no other OS on the system. I have confirmed that I have network access.

Based on no response from trunglv, i am hoping that means his last idea worked. I am about to try it as well, and will update with the results.

before doing that could you check the checksum of the iso you downloaded

if it fine then try Fedora Media Writer from here

Checksum is good to go. I am downloading Fedora now, to try installing. I am also double checking my network config.

My previous setup was I had a gl.inet router hardlined into the server, and routing traffic through my home wireless network (essentially to function as a wireless NIC). When remoting into the inet admin page from my laptop on the inet network, I had internet access from my laptop. I was also able to ping the server. This is what my assumption was based on in terms of my network being good to go.

The Server is now pulling an IP through DHCP from my primary router. “Setting up installation source” is taking much longer than it did before, so I am taking that as a good sign. I’m going to give it a bit, and if it works I will update here.

fedora media writer is the app on the left side of the screen here the direct link

the link was just reference so you know where it come from

I have it working. First of all, thank you @JustSomeone . The problem in the end was a networking configuration.

the solution offered by trunglv did not work. I could not find a way to point to a local drive, it had to be a network location. If I had a file share on my network it may have worked, but i did not. The solution was to add to my DNS list. When my server pulled a DHCP address, it pulled two DNS servers with internal addresses. I added the and it immediately worked.

Thank you again for the help. I hope this helps others as well.

glad to know that you find away to solve it and you very welcome :slight_smile: