Can't find Local Media option in the installation source

I try to use Rocky 8.4 x86_64 dvd1.iso to install rocky linux.
I select local media on the software installation source and successfully complete the installation on VM, but when I installed it on the laptop, I couldn’t select local media option except the network one.

How can I use local media smoothly?

Thanks!!!

@alan, welcome to the Rocky Linux Forums.

I can only offer that I would expect the Local Media to be presented in the same fashion as the VM.
But, maybe we should ask…
Did you extract the ISO to a USB flash drive, or is it extracted/burned to a DVD dual-side physical media, and you are using that physical DVD in your machine with a DVD drive.

It is always better to ask the questions for obvious answers first, instead of us guessing or assuming anything.

Write back! I am off to bed in a little while, but others will read this and get back to you as well.

I used Rufus to write to usb and it popped up a dialogue which asked if I wanted ISO mode or DD mode. ISO mode will not work.

When I did the same with the latest centos, Rufus said that it would use DD mode and I didn’t have to select it so there is something different in the way the ISOs are created.

I’m sorry I didn’t state the problem completely.

Although the linked image file is centOS, I encountered the same problem in rocky linux.


I couldn’t select local media option except the network one.

How does VMware present the ISO to VM? Are there options?

The GUI is not the only view to installer. There are text-based virtual consoles too.
Ctrl-Alt-Fn should get you to those (if VMware allows).
I would check via CLI what is mounted at this stage of install.