Rocky Linux workstation goes to terminal

I am a happy user of Rocky Linux 8.5 workstation and I use it for my main day to day desktop.
Sometimes I will go AFK for eg 10 minutes, and when I come back, Gnome shell is gone and instead I have a CLI screen that asks me to log in.
I have tried to press Ctrl-Alt-F key combinations including F7 to hopefully get me back to Gnome Shell but this has not worked.
I am not familiar with how to use this CLI, but this issue happens quite often so I learned to log in and then enter shutdown -r to do a reboot.
I am wondering what may cause RL to go to the CLI screen?
And is there anything I could do to prevent this from happening?
Thanks ahead of time.

The graphical login screen is on Ctrl-Alt-F1 and after login the graphical screen takes the next free which is probably Ctrl-Alt-F2 in most cases. This means that the graphical session does not replace the graphical login screen, this wasn’t the case with RHEL7 or older.

Maybe you find something in the logs. After it happened again, try

$ journalctl --since -10m      # or how long you were away
1 Like

Regarding the original post, it sounds like something is wrong. When you use ‘gdm’ to log in to ‘Gnome’ and then leave it idle, it will “sleep” after 15 minutes. Pressing any key (escape) shoudl either show ‘gdm’ ready for password, ot bring the desktop back exactly as you left it.

Hi @ anemarkus,
Thanks for the information.
That is very helpful.
I will check the logs next time it happens.

Hi @ gerry666uk,
The behaviour you are describing is what happens most of the time.
Just on occasion the issue happens.
I will check the logs next time and hopefully that will provide some insight…

It’s worth checking the logs. It uses power management to turn off the screen, so there could be some kind of hardware issue that’s causing it to crash the gui and fall back to the terminal.

1 Like