Help: update and reboot. spinning rocky icon

Good morning.

I updated my rocky 8 server this morning. and performed a reboot.
the menu lists 4.18.0-425.10.1.e18_7.x86_64 8.7
After rebooting, the boot kind of hangs. get the spinning circle on the desktop.
Im not able to see boot messages, because the desktop gui hides everything.

If I select older 4.18.0-425.3.1.e18.x86_64 8.7 it recovers and is fine.

my console is java iKVM viewer.
What kind of steps can I take to troubleshoot the problem further?
Im not sure how to stop the desktop from launching, to see console messages.

You are the second post encountering issues with this kernel update.

Can you get to a console using the key combination: Ctrl+Alt+F2? If so then log in at the prompt and enter dmesg at the prompt, or even better:

dmesg | tail > dmesg.txt

Then reboot to the working kernel and post the output from that file here.
That should confirm it is that same issue as the other poster. From there I think the mods here will have a course of action to recommend.


I learned a couple of new things…
Ctrl-Alt-F2 works on my laptop… I would drop to console in ubuntu. lol.

I attached a monitor and keyboard rebooted.
locally, Ctrl-Alt-F2 would not work. it was not finished booting.

Pressing ESC would toggle between graphics and the boot. I took a picture… and then I also tried ESC from iKVM console. that worked. I screen shot the console.
the image looks better than camera pic. :slight_smile:

Please see attached.

Please let me know what other info to provide.
My motherboard is a Supermicro X11SSH-CTF

Just booted into my RL8 install and upgraded to this kernel and I have no issues. I will have to assume that you have a different issue than other poster.

Can you boot into single user mode? The old way still works so at the grub menu select this kernel hit “e” to edit the end of the line beginning with linux where you add a space and the numeral “1” without quotes.

If that gets you to a prompt then you can log in as your user and then view your log file thus:
sudo less /var/log/messages

Look in the time range of your last failed boot for the lines you posted and then scroll back up as I think the errors are above that.

Other things that have come up lately for users is mounting NAS boxes that have outdated cifs protocol using smb version 1, which is no longer supported in the kernel.

thanks. I tried this… and it doesnt get any more in the boot before it hangs.

here is a screen shot of my linux line.
I have IPv6 disabled. could that be contributing?

There is also that error about BIOS. I guess look a newer version?


Also, I removed gvfs-smb. I dont use samba for anything on this server.

So you can boot into the previous kernel and then search /var/log/messages from there. You’ll have to provide us more information than you have for us to diagnose / speculate what the issue is. Do you load any kmod modules for your video? Read the man page for inxi and post your system information here.