Rocky Linux 9.3 - Blank Login Screen?


I’ve built a STIG’d version of RL9.3 VM in an ESXi 7 environment.

I’m able to login, install packages, do stuff etc…

But when the screen locks and I walk away for a few hours, I come back to a black screen with a blinking white dot top left. I can’t seem to access the UI until I completely reboot the VM. I disabled Screen Off completely and awaiting to see if it goes blank.

I also tried to reload open-vm-tools, but to no avail? Please advise, thanks!

PS: resizing the window doesn’t do it this time…

Hardening an installation to such an extent as STIG is rather complicated; there are tons of things which have been changed as a result.

You first verified there were no such issues on a separate Rocky 9.3 VM on the same ESXi host prior to hardening, right?

If you’re actually talking about a full GUI installation on this, I wonder if it might have anything to do with wayland vs. x11…

I also did a “VanillaVM” with no changes… same deal the GNOME UI eventually crashes when it’s in screensaver mode and then I have to do the key combo to bring it back, so that rules out STIG in my book… Doing some more research on the interwebs, it’s been a reoccuring issue with GNOME through the years :confused:

So “rules out STIG” means it wasn’t related to STIG in this case

STIG is a security baseline for hardened system as suggested by DISA.

When my VM goes into idle, eventually the screen saver kicks in and then the whole UI dissapears.

To recover the UI, I need to do Shift+Alt+F1 and spam it a few times…

At first I thought it was a STIG mod that caused that, so I went back and remove any display related security recommendation, disable screensaver etc… And yet after a while, the screen still goes blank with a white dot.

So for fun I installed an “unaltered” version of the OS on another VM, and I still get that issue.

I also installed that OS on a Dell Server and I still get that issue… now it’s especially annoying when trying to access the UI through a KVM and it doesn’t play ball.

From my findings, it is a GNOME desktop issue for many years.

The exact behaviour happens whether I run my Secure OS version or just a normal User installation version, on a VM or on BareMetal.

So I’m looking at installing XFCE or anything else but GNOME at this point.

OK, so you are saying that if you install default Rocky 9.3 onto a baremetal PC with a UI, and then wait 15 minutes, the screen goes blank and pressing a key doesn’t bring back the UI? But then I’d expect this forum to be full of people complaining about it.

Can you check journalctl at the exact time it goes blank and also at the time you press the keys to see if there is anything strange in the logs.

I can see the 15 minute “blank screen” setting is in two different places.

Settings : Power
Settings : Privacy : Screen Lock

Can you try turning off (all) in both places, and see if it makes the slightest difference?

Can you also confirm if you’re using X server or Wayland?

Once you get 15 min power, the privacy setting follows suite, it’s the same parameter.

I’ve already done that, toggling those things off and setting to “never” does nothing… the screen still goes blank with a white dot and NO it’s not immediately at the 15 minutes timer, it is some time after…

I’ve played with it by setting it to 30 seconds and waiting… moving the mouse bring it back.

But if I leave the system inactive for like 30 minutes to an hour, it then falls into that weird state that only CTRL+Alt+F2 and then F1 brings it back… Basically F2 brings it to a console view and then pressing the same combo but with F1 switches it back and restarts the UI.

“Can you also confirm if you’re using X server or Wayland?” I am using whatever comes default with Rocky Linux 9."

According to xAI Grok:


The default display server for Rocky Linux 9 is Xorg (X server), as it is the more mature and stable option. While Wayland is available as an alternative, it is not the default choice.

And yes, on a vanilla system, I get this error and NO I am not the only one, there’s a few more threads about this. Check my comment history.

I might try Wayland for fun…

I’ve setup another VM in a Boxes Hypervisor for fun…

I don’t know what “grok” is, but it’s wrong.

1 Like

OK, perhaps it’s nothing to do with the lock screen. Did you check the logs at the exact time it happens?

So I found those two threads:

It comes down to this:

sudo vi /usr/lib/systemd/system/gdm.service

               then add "ExecStartPre=/bin/sleep 2"

sudo systemctl daemon-reload
sudo systemctl restart gdm.service

BOOM DONE… the damn login screen stays persistent, even after idle and black screen…

I actually had scripted a whole LightDM with DarkTheme to replace GDM but then a bunch of stuff broke because of GNOME’s native reliance on GDM :confounded:

Few days of torture and this seems to be the fix…

I’ve found the black screen + white curse window being an issue with RHEL going back as far as 6 and 7… :confused:

This had become distressing, I built this golden image to go on an army of servers, but when they went idle for too long, it was black screen and white curse, depending on the kvm Alt+F1 wasn’t a viable option.

and nope… it’s still trash, overnight still the UI stopped >__< ugh

The ‘Adamsdesk’ forum post is a bad comparison; it’s a different o/s, and they disabled wayland, and they’re using nvidia, plus it’s not even the same issue. They are talking about ‘gdm’ not starting automatically. You should not be changing any .service files, as those are “system supplied”. The only part of that post that makes sense, is where they show the exact entries in the log file at the exact time of the issue.