New server with Rocky Linux 9.3 -- GUI broken? Any Help Appreciated

Hi all,

I apologize if this is not the correct area to ask this, however, I just set up a linux workstation in my lab with the Rocky 9.3 OS.

Everything was working great until I had to shut down the machine (so I can plug into a UPS system) and since then I have had a few issues that seem to be serious.

When I was originally trying to start the machine back up one of the messages I saw is attached as a photo. Someone has told me it might be something with the grub file? it may have been lost some how? It also seemed to selectin the wrong OS partition (I tried to upload a second photo showing the menu, but I cannot oupload more than one image as a new user – will try in comments).

Any help is appreciated!

I should also mention, that after I was able to get the computer booted up again with the correct partition, once I logged off of my account on the gui, it now only shows a black screen with a blinking cursor in the top left. But, the command line works completely fine and I can ssh in no problem.

Also, here is the photo of the menu, the top one in the list does not work, the second does work.

Ok, I’m going to make an assumption:

Did you install updates prior to powering down the machine to connect it to the UPS?

If so, in the GRUB boot menu that you show, what happens if you choose an older kernel from the boot list?

1 Like

You assumed correctly I believe, there was a message when I was able to reboot it back up that updates were installed. But I didnt see any warning that the shutdown would interrupt anything…

I havent tried any of the lower ones on the list, but if I do not select the second option it boots up fine, but then the gui crashed or something because now I can only see a black screen with the blinking cursor in the top left.

Could I some how repair or redo the updates?

So, If you boot the top option (the newest kernel) what happens?

For instance, this is the kernel running on my recently updated laptop:


When I select that top option I get an error saying it cannot mount root:

Ok, So hopefully I have all of the facts correct now. You can boot the second option in the GRUB menu and it boots, but then crashes afterward, and the 1st and 3rd option won’t boot at all, but display the error instead?

At one point, I thought that perhaps one kernel would boot and the others would not. If you are getting a crash on the only bootable kernel too, then this might be a disk issue, but I’d have to defer to someone more knowledgeable about this sort of error.

I’m also wondering if (since the second option boots but crashes) there isn’t a disk issue in play here. I’m hoping that someone else here has a good suggestion for you to try.

I havent tried the third one, just the first, which prompted that error message. The second one booted up fine, and the command line is working fine, but yeah after one of my students just logged out of the account on the gui, all of a sudden the gui stopped. But again, the computer is running completely fine as command line not sure if that is a good sign or not.

The computer is less than three weeks old and the OS is on a SSD - does this reduce the odds that its a disk issue?

Well it’s probably not a physical disk issue, no. But there could be corruption. I’d be curious to know what happens when you boot up the third (oldest, as in the originally installed kernel). Does it just run, or does it have the same issue?

I’m going to have to drop here soon. I’m still hopeful that someone else will have an idea.

I have the same issue with 9.3 on a clean install sadly… I haven’t been able to find the root cause.

Only CTRL+Alt+F1 fixes that for me :confused:

Same here. fairly new installation of 9.3 and GUI stops after an update. In version 8 I could just tell it to install the NVIDIA driver again and that was a fix, until another update, but this doesn’t work in 9.3. Actually uninstalled the NVIDIA driver and installed again but to no avail. I hope someone has a fix for this.

also, when I run nvidia-smi to check the nvidia driver it says no devices were detected. We have tried uninstalling the driver and reinstalling using dnf install.