Rocky Linux 9.0 RPI image fail to boot on RPI3 / Workaround


I tried the official Rocky Linux 9.0 SIG image for the Raspberry Pi on my RPI 3 Model B v1.2, but it fails to boot.

During the boot process, the brcmfmac module crashes. Consequently, several services (for example, Security Auditing Service) fail to start, and the system never reaches the login prompt.

Workaround: Disable loading the brcmfmac wifi driver:
After you copied the image to the SD card:

  1. Mount the root partition, for example:
    # mount /dev/sda3 /mnt/
  2. Create the /mnt/etc/modprobe.d/01-rpi3-blacklist.conf file with the following content:
    blacklist brcmfmac
  3. Unmount /mnt/:
    # umount /mnt
  4. Boot the SD card in your RPI 3.

I experienced this issue on Rasberry Pi 3 model B.

I want to write the following steps for anyone experiencing this issue:
4. Now you should be able to successfully boot into Rocky 9 and become root.
Username: rocky, Password: rockylinux

xz -d -k /lib/firmware/brcm/brcmfac43430-sdio.raspberrypi,3-model-b.xz

Probably there is a corresponding file for vanilla R.Pi 3 (I forgot to check)

rm -f /etc/modprobe.d/01-rpi3-blacklist.conf


  1. You should be able to see the wireless interface on your R.Pi (In my case it was labeled wlan0)

ip a / ifconfig

xz -d -k /lib/firmware/brcm/brcmfac43430-sdio.raspberrypi,3-model-b.xz

Probably there is a corresponding file for vanilla R.Pi 3 (I forgot to check)

Can I confirm is it this file you mean? I’ve tried with this file but the wlan0 still not showing. Am I missing anything? :face_exhaling:


Hey, I apologize that I have not been on top of this at all. But I believe this should be fixed by default in the latest images. They are currently being tested now, you can grab them from here: Index of /RockyRpi .

Unfortunately, I don’t have an rpi3 to test on, only rpi4. Anyone who has the appropriate hardware: please check it out and let me know!