How to enable wifi in my HP Stream laptop?

I recently installed Rocky Linux 9.2 on an old HP Stream laptop with a Broadcom BCM943142 [14e4:4365] wifi adapter. The install completed successfully, but Rocky Linux doesn’t recognize the Broadcom adapter. I did some searching online on how to find and install the appropriate driver, but most of the solutions I found applied to Ubuntu. Can anyone give me guidance on how to get Rocky Linux to work with my Broadcom adapter? Thanks in advance to all who respond.

assuming nothing of your knowlege, as root in a terminal window:
modprobe b43
modinfo b43
,and then
lsmod|grep b43

and if they appear to work, then
ip link show
if that works then we can give you steps to make that permanant.
regards peter

It appears that the device with [14e4:4365] is supported by the bcma driver. Not sure why the driver is not loaded automatically but can you try:

modprobe bcma

Hey, this might be a possible solution:


Install RPM Fusion non-free (I dont think you need the free)

sudo dnf install akmod-wl

Reboot may be required

This works for me with Rocky 8.x

Hope it helps :slight_smile:


Thank you for your suggestion. When I entered the first modprobe command, I got the error message

modprobe: FATAL: Module b43 not found in directory /lib/modules/5.14.0-284.11.1.el9_2.x86_64

I assume the error means I do not have the appropriate Broadcom adapter module.


Thank you for your suggestion. When I entered the “modprobe bcma” command, I was returned to the command prompt without seeing any messages, and the Broadcom adapter was not activated. Even adding the “-v” option to the command did not produce any messages.


Thank you for your suggestion. Using a Panda Wireless PAU06 USB adapter, I was able to install the rpmfusion repo and successfully install akmod-wl. Also, I did notice that “broadcom-wl” was one of the dependencies installed. However, when I rebooted the system, it appears that my video configuration was altered, since my screen froze with only a blinking underscore character in the upper left corner after the Gnome Display Manager started. In other words, my graphics mode no longer worked.

I reformatted my hard drive and reloaded Rocky Linux 9.2, then tried the same procedure, only installing “broadcom-wl” instead of “akmod-wl”. Unfortunately, akmod-wl was installed as a dependency of broadcom-wl, and the end result was the same.

Really sorry to hear that - that is not the intended consequence for me trying to help out.
If you are not sick and tired of trying things, I would suggest you try Rocky 8. You mentioned your laptop is older, and Rocky 9.x requires more modern hardware. I run Rocky 8 currently on a Dell E6510 made in 2010 and everything works great.

Try running “lsmod | grep bcma” to see if the module has been loaded.

I ran “lsmod | grep bcma” and found no matches. I’m pretty sure the module doesn’t exist.

No worries. This is a hobby project, not one my job depends on. I do appreciate your efforts.

I would say that trying enterprise linux of any origin on an old cheap laptop is likely to have problems like this.
enterprise linux of any make is focused on being a server OS and then a professional workstation and therefore expects high end hardware.
I run Fedora 38 on my old ASUS UX31a thats of 2010 era and it all works 100%.
the Fedora kernel carries many more devices than the Rhel one does, and is more likly to have the driver (and the broadcom firmware) that you need.
The B43 driver does load on fedora 38. I still dont know if its the driver you need, it could be the other one.
Therefore I would try that, Ive installed Fedora 38 on a wide variety of hardware old and newish and it all works. I use the KDE spin…
the kde spin is a live CD so you can try before you buy (or install)
Fedora is 99% the same to configure/setup as EL so if its learning how to do stuff under EL distributions rather than rock steady stability and binary compatibility, fedora will be so close you wont know the difference.
regards peter

I successfully installed Fedora 38 on my laptop. “lsmod” shows that b43 is installed, as well as bcma, which points to b43. However, “ip link show” only lists the loopback interface.

searching around it seems you need to add rpmfusion nonfree and then install broadcom-wl rpm
broadcoms usualy need firmware, and hopefulliy that pulls in the firmware blob.
search broadcom wlan firmware on google and it should explain.
typing on my tablet right now so if i get a chance ill check on my pc later.
regards peter


this site speaks about an older fedora but the result is the same

when i install the broadcom-wl it also installs

dnf install broadcom-wl
Last metadata expiration check: 0:00:07 ago on Sat 19 Aug 2023 12:04:57 BST.
Dependencies resolved.

Package Architecture Version Repository Size

broadcom-wl noarch rpmfusion-nonfree 24 k
Installing dependencies:
akmod-wl x86_64 rpmfusion-nonfree 5.5 M
akmods noarch 0.5.7-10.fc38 fedora 33 k
bison x86_64 3.8.2-4.fc38 fedora 1.0 M
elfutils-libelf-devel x86_64 0.189-3.fc38 updates 23 k
flex x86_64 2.6.4-12.fc38 fedora 313 k
kernel-devel x86_64 6.4.10-201.fsync.fc38 16 M
kernel-devel-matched x86_64 6.4.10-201.fsync.fc38 141 k

Transaction Summary

Install 8 Packages

Total download size: 23 M
Installed size: 78 M
Is this ok [y/N]: y
Downloading Packages:
(1/8): elfutils-libelf-devel-0.189-3.fc38.x86_64.rpm 230 kB/s | 23 kB 00:00
(2/8): akmods-0.5.7-10.fc38.noarch.rpm 300 kB/s | 33 kB 00:00
(3/8): flex-2.6.4-12.fc38.x86_64.rpm 1.0 MB/s | 313 kB 00:00
(4/8): broadcom-wl- 59 kB/s | 24 kB 00:00
(5/8): bison-3.8.2-4.fc38.x86_64.rpm 2.3 MB/s | 1.0 MB 00:00
(6/8): kernel-devel-matched-6.4.10-201.fsync.fc38.x86_64.rpm 115 kB/s | 141 kB 00:01
(7/8): kernel-devel-6.4.10-201.fsync.fc38.x86_64.rpm 5.0 MB/s | 16 MB 00:03
(8/8): akmod-wl- 270 kB/s | 5.5 MB 00:20

Total 1.0 MB/s | 23 MB 00:22
Running transaction check
Transaction check succeeded.

although the older article refers to kmod-wl, above pulls in akmod-wl

akmod will build the driver for you, whereas the kmod is prebuilt.

so either way is right.

regards peter


So, to enable my Broadcom wifi card in Fedora, I need to perform the same process that didn’t work for Rocky Linux? I’m hesitant to use any distro from Red Hat, for reasons that are probably familiar to everyone on the Rocky forums, and the only reason I tried Fedora was the possibility that it would support my wifi card immediately upon installation. I think I’ll uninstall Fedora and try something else.

Still, your suggestion to try other distros is a good one. Perhaps Ubuntu might work. And I haven’t given up hope that someone might know of a Driver Utility Disk or the like that would allow Rocky to talk to my Broadcom card. At any rate, I do appreciate your suggestions, and I thank you for them.

I realy dont think you understand, the broadcom-wl is propriety and is not allowed to be shipped with a distribution without a license.
thats why its in the nonfree repo.
loads of distributions do this to avoid being subject to the license terms of the hardware manufacturer.
broadcom has always been a bit of a problem with linux in that sense with its firmware same as nvidia is with its drivers, and loads of other hardware companies are the same.
The only thing you can do to avoid it, is open up the laptop and change the wifi card for an intel one like i did.
you may find the same in other distros, try mageia thats also rpm based, not a million miles from fedora in some ways, but they automatically enable the nonfree repos during the install after you check a tick box.
The fedora people seem to be a bit to purist when it comes to proprietary stuff in my opinion.

try googling this subject you will find most of the distributions have issues with broadcom wifi chips.

And I get that you are frustrated, that it does not work out of the box, but I can say that most intel wifi cards and most atheros do work out of the box.

not sure if this is your exact model, but you get the idea.

regards peter


Thanks for the suggestion to try mageia. However, yesterday I downloaded Ubuntu 22.04.3 LTS, checked the option to include the proprietary wifi hardware drivers as I installed it, and it worked. So I’m good. Thanks again for all your suggestions and guidance.