Broadcom wifi doesn't work. Dell Latitude E6500. Help

Dear Members,

please help me. I don’t understand this kernel module thing.
The problem is I have a Dell Latitude E6500. It has a Wifi card but I cannot put in operation. I don’t understand how it works . I play with the modprobe but I cannot get the logic. If I enter lspci -nnk it says kernel module is: ssb . I found the b43 or b43legacy kernel module could be a solution. I tried to load in, I tried to unload the ssb . I tried to put it on the blacklist but Wifi card still does not operate. I feel I don’t understand the logic. Could anybody give a little hint ? Thank you in advance.

# dmesg | grep -i b43

I got the site: en:users:drivers:b43 [Linux Wireless]

Hi, I have run Rocky 8.x on a number of Dell E6510’s and so I can relate :slight_smile:

I am going to assume your question is not about kernel module how to (as per your title) but you want to get your wifi card running.

My suggestions:

  • Run Rocky 8.x not 9.x (You did not specify what you are running)

  • There are many different wifi cards from different manufacturers.

  • The kernel nor Rocky will have all drivers for all makes and models of cards.

  • Many Intel wifi cards are supported by kernel and hence Rocky.

  • The E6500 is at least 10 years old and over time, hardware including wifi cards, often gets replaced in older laptops, so you may have any make and model wifi card, not the original (likely intel) one.

It is important to know which card you have. You can do that by:

  • Opening up the laptop and seeing what the wifi card says - it is very easy to do - see
  • Run lspci in Terminal. Look for “02:00.0 Network controller” - Eg I have an Intel wifi card and the result is: “02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)”

If you have a Broadcom wifi card, then you can try the following:

Install RPM Fusion non-free (I dont think you need the free) - you can do this by going to the site and following the links.

sudo dnf install akmod-wl


If that does not work, I suggest you purchase an Intel wifi card (they dont cost much used) and try that.

I realize this may not be easy to do with only having dog paws :wink:

Hope that helps.

1 Like

This is the system.

Static hostname: testcomp.test.local
         Icon name: computer-laptop
           Chassis: laptop
        Machine ID: faafcc43312340b599262dd363aa7a51
           Boot ID: 1d068ee6b7594f49bd10c5745619aa07
  Operating System: Rocky Linux 8.8 (Green Obsidian)
       CPE OS Name: cpe:/o:rocky:rocky:8:GA
            Kernel: Linux 4.18.0-477.27.1.el8_8.x86_64
      Architecture: x86-64
0c:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)
        Subsystem: Dell Wireless 1510 Wireless-N WLAN Mini-Card
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 3
        Region 0: Memory at f69fc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=2 PME-
        Capabilities: [58] Vendor Specific Information: Len=78 <?>
        Capabilities: [e8] MSI: Enable- Count=1/1 Maskable- 64bit+
                Address: 0000000000000000  Data: 0000
        Capabilities: [d0] Express (v1) Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
                        ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset- SlotPowerLimit 6.500W
                DevCtl: CorrErr- NonFatalErr- FatalErr- UnsupReq-
                        RlxdOrd- ExtTag+ PhantFunc- AuxPwr- NoSnoop-
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta: CorrErr+ NonFatalErr- FatalErr- UnsupReq+ AuxPwr- TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <4us, L1 <64us
                        ClockPM+ Surprise- LLActRep- BwNot- ASPMOptComp-
                LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes, Disabled- CommClk+
                        ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s (ok), Width x1 (ok)
                        TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
        Capabilities: [100 v1] Advanced Error Reporting
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UESvrt: DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
                CESta:  RxErr+ BadTLP- BadDLLP- Rollover- Timeout- AdvNonFatalErr+
                CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- AdvNonFatalErr+
                AERCap: First Error Pointer: 14, ECRCGenCap+ ECRCGenEn- ECRCChkCap+ ECRCChkEn-
                        MultHdrRecCap- MultHdrRecEn- TLPPfxPres- HdrLogCap-
                HeaderLog: 00000000 00000000 00000000 00000000
        Capabilities: [13c v1] Virtual Channel
                Caps:   LPEVC=0 RefClk=100ns PATEntryBits=1
                Arb:    Fixed- WRR32- WRR64- WRR128-
                Ctrl:   ArbSelect=Fixed
                Status: InProgress-
                VC0:    Caps:   PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
                        Arb:    Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
                        Ctrl:   Enable+ ID=0 ArbSelect=Fixed TC/VC=01
                        Status: NegoPending- InProgress-
        Capabilities: [160 v1] Device Serial Number ab-d9-e5-ff-ff-91-90-4c
        Capabilities: [16c v1] Power Budgeting <?>
Module                  Size  Used by
nft_fib_inet           16384  1
nft_fib_ipv4           16384  1 nft_fib_inet
nft_fib_ipv6           16384  1 nft_fib_inet
nft_fib                16384  3 nft_fib_ipv6,nft_fib_ipv4,nft_fib_inet
nft_reject_inet        16384  4
nf_reject_ipv4         16384  1 nft_reject_inet
nf_reject_ipv6         16384  1 nft_reject_inet
nft_reject             16384  1 nft_reject_inet
nft_ct                 20480  9
nf_tables_set          49152  12
nft_chain_nat          16384  12
nf_nat                 45056  1 nft_chain_nat
nf_conntrack          172032  2 nf_nat,nft_ct
nf_defrag_ipv6         20480  1 nf_conntrack
nf_defrag_ipv4         16384  1 nf_conntrack
ip_set                 49152  0
nf_tables             184320  235 nft_ct,nft_reject_inet,nft_fib_ipv6,nft_fib_ipv4,nft_chain_nat,nf_tables_set,nft_reject,nft_fib,nft_fib_inet
nfnetlink              16384  3 nf_tables,ip_set
dell_rbtn              16384  0
dell_laptop            28672  0
i915                 2908160  1
rfkill                 32768  3 dell_laptop,dell_rbtn
iTCO_wdt               16384  0
iTCO_vendor_support    16384  1 iTCO_wdt
snd_hda_codec_hdmi     73728  1
snd_hda_codec_idt      65536  1
snd_hda_codec_generic    90112  1 snd_hda_codec_idt
wmi_bmof               16384  0
gpio_ich               16384  0
cec                    49152  1 i915
ledtrig_audio          16384  2 snd_hda_codec_generic,dell_laptop
intel_gtt              20480  1 i915
drm_buddy              20480  1 i915
dell_wmi               16384  0
sparse_keymap          16384  1 dell_wmi
i2c_algo_bit           16384  1 i915
snd_hda_intel          53248  0
drm_display_helper    151552  1 i915
snd_intel_dspcfg       28672  1 snd_hda_intel
dell_smbios            24576  2 dell_wmi,dell_laptop
snd_intel_sdw_acpi     16384  1 snd_intel_dspcfg
dell_wmi_descriptor    16384  2 dell_wmi,dell_smbios
dcdbas                 16384  0
coretemp               16384  0
kvm_intel             344064  0
dell_smm_hwmon         16384  0
kvm                   958464  1 kvm_intel
snd_hda_codec         163840  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_idt
pcspkr                 16384  0
ttm                    81920  1 i915
snd_hda_core          102400  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_idt
drm_kms_helper        167936  2 drm_display_helper,i915
irqbypass              16384  1 kvm
lpc_ich                28672  0
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               131072  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
snd_timer              36864  1 snd_pcm
sysimgblt              16384  1 drm_kms_helper
fb_sys_fops            16384  1 drm_kms_helper
joydev                 24576  0
snd                   110592  8 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_pcm,snd_hda_codec_idt
soundcore              16384  1 snd
drm                   577536  6 drm_kms_helper,drm_display_helper,drm_buddy,i915,ttm
i2c_i801               28672  0
wmi                    32768  4 dell_wmi,wmi_bmof,dell_smbios,dell_wmi_descriptor
video                  53248  3 dell_wmi,dell_laptop,i915
acpi_cpufreq           24576  1
xfs                  1585152  3
libcrc32c              16384  4 nf_conntrack,nf_nat,nf_tables,xfs
sd_mod                 53248  4
t10_pi                 16384  1 sd_mod
sg                     40960  0
ahci                   40960  2
libahci                40960  1 ahci
libata                266240  2 libahci,ahci
e1000e                290816  0
serio_raw              16384  0
dm_mirror              28672  0
dm_region_hash         20480  1 dm_mirror
dm_log                 20480  2 dm_region_hash,dm_mirror
dm_mod                151552  12 dm_log,dm_mirror
[user@testcomp ~]$ sudo dnf install
[user@testcomp ~]$ dnf search kmod
Last metadata expiration check: 0:00:35 ago on Sun 08 Oct 2023 05:32:48 PM CEST.
============================================================================================================================ Name Exactly Matched: kmod =============================================================================================================================
kmod.x86_64 : Linux kernel module management utilities
=========================================================================================================================== Name & Summary Matched: kmod ============================================================================================================================
akmod-VirtualBox.x86_64 : Akmod package for VirtualBox kernel module(s)
akmod-ndiswrapper.x86_64 : Akmod package for ndiswrapper kernel module(s)
akmod-v4l2loopback.x86_64 : Akmod package for v4l2loopback kernel module(s)
akmod-wireguard.x86_64 : Akmod package for wireguard kernel module(s)
akmod-xtables-addons.x86_64 : Akmod package for xtables-addons kernel module(s)
akmods.noarch : Automatic kmods build and install tool
centos-release-kmods.noarch : CentOS Kmods SIG package repositories
kmodtool.noarch : Tool for building kmod packages
libmikmod-devel.x86_64 : Header files and documentation for compiling mikmod applications
================================================================================================================================ Name Matched: kmod =================================================================================================================================
VirtualBox-kmodsrc.noarch : VirtualBox kernel module source code
kmod-VirtualBox.x86_64 : Metapackage which tracks in VirtualBox kernel module for newest kernel
kmod-VirtualBox-4.18.0-477.10.1.el8_8.x86_64.x86_64 : VirtualBox kernel module(s) for 4.18.0-477.el8_8
kmod-kvdo.x86_64 : Kernel Modules for Virtual Data Optimizer
kmod-libs.x86_64 : Libraries to handle kernel module loading and unloading
kmod-libs.i686 : Libraries to handle kernel module loading and unloading
kmod-ndiswrapper.x86_64 : Metapackage which tracks in ndiswrapper kernel module for newest kernel
kmod-redhat-oracleasm.x86_64 : oracleasm kernel module
kmod-v4l2loopback.x86_64 : Metapackage which tracks in v4l2loopback kernel module for newest kernel
kmod-v4l2loopback-4.18.0-425.3.1.el8.x86_64.x86_64 : v4l2loopback kernel module(s) for 4.18.0-425.el8
kmod-wireguard.x86_64 : Metapackage which tracks in wireguard kernel module for newest kernel
kmod-wireguard-4.18.0-425.10.1.el8_7.x86_64.x86_64 : wireguard kernel module(s) for 4.18.0-425.el8_7
kmod-xtables-addons.x86_64 : Metapackage which tracks in xtables-addons kernel module for newest kernel
kmod-xtables-addons-4.18.0-425.3.1.el8.x86_64.x86_64 : xtables-addons kernel module(s) for 4.18.0-425.el8
libmikmod.x86_64 : A MOD music file player library
mikmod.x86_64 : Console music module player
perl-Test-MockModule.noarch : Override subroutines in a module for unit testing
python3-kmod.x86_64 : Python module to work with kernel modules
[bsapi@tankcsapda ~]$ dnf search akmod
Last metadata expiration check: 0:00:59 ago on Sun 08 Oct 2023 05:32:48 PM CEST.
=========================================================================================================================== Name & Summary Matched: akmod ===========================================================================================================================
akmod-VirtualBox.x86_64 : Akmod package for VirtualBox kernel module(s)
akmod-ndiswrapper.x86_64 : Akmod package for ndiswrapper kernel module(s)
akmod-v4l2loopback.x86_64 : Akmod package for v4l2loopback kernel module(s)
akmod-wireguard.x86_64 : Akmod package for wireguard kernel module(s)
akmod-xtables-addons.x86_64 : Akmod package for xtables-addons kernel module(s)
================================================================================================================================ Name Matched: akmod ================================================================================================================================
akmods.noarch : Automatic kmods build and install tool

Free does not contain the akmod-wl.
Nonfree repo has been added.

# sudo dnf -y install
# dnf search akmod-wl
# sudo dnf -y install akmod-wl
[user@testcomp ~]$ nmcli
enp0s25: connected to enp0s25
        "Intel 82567LM"
        ethernet (e1000e), 00:26:B9:9A:86:42, hw, mtu 1500
        ip4 default
        route4 metric 100
        route4 default via metric 100
        inet6 fe80::226:b9ff:fe9a:8642/64
        route6 fe80::/64 metric 1024

lo: unmanaged
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

wlp12s0: unmanaged
        "Broadcom and subsidiaries BCM4322"
        wifi (wl), 90:4C:E5:91:AB:D9, plugin missing, hw, mtu 1500

DNS configuration:
        interface: enp0s25

Use "nmcli device show" to get complete information about known devices and
"nmcli connection show" to get an overview on active connection profiles.

Consult nmcli(1) and nmcli-examples(7) manual pages for complete usage details.
[user@testcomp ~]$ sudo dnf -y install NetworkManager-wifi NetworkManager-ppp
Last metadata expiration check: 0:11:41 ago on Sun 08 Oct 2023 05:40:01 PM CEST.
Dependencies resolved.
 Package                                                                  Architecture                                                Version                                                                      Repository                                                   Size
 NetworkManager-ppp                                                       x86_64                                                      1:1.40.16-4.el8_8                                                            baseos                                                      163 k
 NetworkManager-wifi                                                      x86_64                                                      1:1.40.16-4.el8_8                                                            baseos                                                      200 k
Installing dependencies:
 crda                                                                     noarch                                                      3.18_2020.04.29-1.el8                                                        baseos                                                       23 k
 iw                                                                       x86_64                                                      4.14-5.el8                                                                   baseos                                                       89 k
 ppp                                                                      x86_64                                                      2.4.7-26.el8_1                                                               baseos                                                      403 k
 wpa_supplicant                                                           x86_64                                                      1:2.10-1.el8                                                                 baseos                                                      2.1 M

Transaction Summary
Install  6 Packages

Total download size: 3.0 M
Installed size: 6.8 M
Downloading Packages:
(1/6): crda-3.18_2020.04.29-1.el8.noarch.rpm                                                                                                                                                                                                          61 kB/s |  23 kB     00:00    
(2/6): NetworkManager-ppp-1.40.16-4.el8_8.x86_64.rpm                                                                                                                                                                                                 371 kB/s | 163 kB     00:00    
(3/6): NetworkManager-wifi-1.40.16-4.el8_8.x86_64.rpm                                                                                                                                                                                                396 kB/s | 200 kB     00:00    
(4/6): iw-4.14-5.el8.x86_64.rpm                                                                                                                                                                                                                      582 kB/s |  89 kB     00:00    
(5/6): ppp-2.4.7-26.el8_1.x86_64.rpm                                                                                                                                                                                                                 1.6 MB/s | 403 kB     00:00    
(6/6): wpa_supplicant-2.10-1.el8.x86_64.rpm                                                                                                                                                                                                          3.0 MB/s | 2.1 MB     00:00    
Total                                                                                                                                                                                                                                                1.8 MB/s | 3.0 MB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                                                                                                                             1/1 
  Installing       : wpa_supplicant-1:2.10-1.el8.x86_64                                                                                                                                                                                                                          1/6 
  Running scriptlet: wpa_supplicant-1:2.10-1.el8.x86_64                                                                                                                                                                                                                          1/6 
  Running scriptlet: ppp-2.4.7-26.el8_1.x86_64                                                                                                                                                                                                                                   2/6 
  Installing       : ppp-2.4.7-26.el8_1.x86_64                                                                                                                                                                                                                                   2/6 
  Running scriptlet: ppp-2.4.7-26.el8_1.x86_64                                                                                                                                                                                                                                   2/6 
  Installing       : iw-4.14-5.el8.x86_64                                                                                                                                                                                                                                        3/6 
  Installing       : crda-3.18_2020.04.29-1.el8.noarch                                                                                                                                                                                                                           4/6 
  Installing       : NetworkManager-wifi-1:1.40.16-4.el8_8.x86_64                                                                                                                                                                                                                5/6 
  Installing       : NetworkManager-ppp-1:1.40.16-4.el8_8.x86_64                                                                                                                                                                                                                 6/6 
  Running scriptlet: NetworkManager-ppp-1:1.40.16-4.el8_8.x86_64                                                                                                                                                                                                                 6/6 
  Verifying        : NetworkManager-ppp-1:1.40.16-4.el8_8.x86_64                                                                                                                                                                                                                 1/6 
  Verifying        : NetworkManager-wifi-1:1.40.16-4.el8_8.x86_64                                                                                                                                                                                                                2/6 
  Verifying        : crda-3.18_2020.04.29-1.el8.noarch                                                                                                                                                                                                                           3/6 
  Verifying        : iw-4.14-5.el8.x86_64                                                                                                                                                                                                                                        4/6 
  Verifying        : ppp-2.4.7-26.el8_1.x86_64                                                                                                                                                                                                                                   5/6 
  Verifying        : wpa_supplicant-1:2.10-1.el8.x86_64                                                                                                                                                                                                                          6/6 

  NetworkManager-ppp-1:1.40.16-4.el8_8.x86_64            NetworkManager-wifi-1:1.40.16-4.el8_8.x86_64            crda-3.18_2020.04.29-1.el8.noarch            iw-4.14-5.el8.x86_64            ppp-2.4.7-26.el8_1.x86_64            wpa_supplicant-1:2.10-1.el8.x86_64           


And finally.

wlp12s0: connected to R49
        "Broadcom and subsidiaries BCM4322"
        wifi (wl), 90:4C:E5:91:AB:D9, hw, mtu 1500
        route4 metric 600
        route4 default via metric 600
        inet6 fe80::dc72:891e:4fbf:97a3/64
        route6 fe80::/64 metric 1024

Glad to see that that got it working for you

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.