Rocky iso downloads seem to be corrupted

Currently experiencing issues installing Rocky 9, 8, or CentOS 7 version to system: every download seems to be corrupted, in that various commands either do not show up (ss, iwconfig, hostname, ifup, ifdown, ping, ip link set dev up/down, dhclient, nmcli doesn’t enable wifi adapters).

Also, various files show up as being empty:

  1. Downloaded Rocky version 9.iso files (minimal install, and dvd) directly from the Rocky downloads page - scanned the file with ESET to confirm non-virus infection, then checked and confirmed SHA256 signature.
  2. Fully formatted USB drive on a Windows 10 system - then installed said .iso file with BalenaEtcher.
  3. Tested installation before starting the install process (chose option 2).
  4. Installed and rebooted the system: tested installs then manifest issues mentioned above.

Attempted to perform the installation with torrented dvd copy obtained from the torrent link on the downloads page. Performed the same steps above with scanning and hash checking - same result occurred.

System is an HP Envy system, I5 CPU, 16GB Ram, 1TB HD.

Has anyone run into issues with corrupt installations from the download page - and if so, are there any suggestions on how to deal with this?

I am running RL9.1 and those commands are deprecated and if you are using old scripts that depend on them you will have to abandon them. There was a period where you could migrate certain configs but I don’t know if that method is still available. I’m sure someone on here will be able to advise you on the new tools.

Not using old scripts - just using the latest install for my RHCSA (or, at least, trying to). I don’t suppose there is a site that has the current list of Linux commands, so that we can keep up?

I’m still thinking that the downloads are being corrupted somehow, as the necessry files (like /etc/resolv.conf, and /etc/hostname) shows no text - whether I’m signed in as a regular user, or as root.

I’ll try my luck with wget and cURL after work…

List of commands that one can find from typical Linux installation and list of commands to manage RHEL are not necessarily identical.
The latter might be springled among

Installed what set of packages? Minimal, GUI Server, or … ?

IIRC, the wifi sub-package of NetworkManager is not included in Minimal. One can install packages from the install media even after the installation. (I don’t know what “RHCSA” is, but I’d guess that it includes knowing how to use the repo that is on the media.)

A service manages hostname. One talks to the service with hostnamectl.
If name is not set (in /etc/hostname?) – which is the default, then “transient” name from DHCP is used.
If there is no connection to DHCP server, then the name probably remains “localhost.localdomain”.

Likewise, /etc/resolv.conf is written by NetworkManager, if there is something to write. (One can change that by change of NM’s config.)

I originally tried with the minimal installation, as I figured that I would still be able to get onto the Internet, to practice installing what I needed. I then tried the DVD install, seeing as how I wasn’t having much luck with the minimal install.

RHCSA is the Red Hat Certified System Administrator certification.

I also tried enabling both Ethernet and wifi with nmtui, or nmcli - neither allowed me to access online.

There are “small” and “full” image. They differ on what packages they have.

The installer has package selection where you choose what set of packages to install; you won’t install everything from image.
I usually choose “Minimal install” even from full “DVD” image.

One needs packages that provide wifi utils before nmcli can use wireless interfaces. I don’t use wifi, so don’t know which packages.

Yes - I understand that the small and full images differ. But I figure that with the minimal package, I should still see some text in the /etc/resolv.conf file in order to access the internet…

Instead, the page is blank.

Regarding the commands that I inputted, these commands (and file locations) were current as of CentOS 7, I think, so…confused shrug

There’s nothing wrong with the images. If you don’t configure a network device during your installation, /etc/resolv.conf is going to remain empty, as you have not told Network Manager what to do.

If you have an ethernet device for example and nothing is plugged in, it will be off, thus the behavior you see. Otherwise, it defaults to DHCP and will be on. For wireless devices, you would have to configure it in the network pane of the installer. Doing this should install the required wifi network manager components if necessary (only from the DVD media or net installs).

No ethernet available on this installation for the purpose of this demonstration.

After the installation, /etc/resolv.conf doesn’t exist in this case. /etc/hostname is empty in this case also, because it wasn’t set.

To set a hostname, use hostnamectl
To configure a network device, use nmcli. This includes turning a device on or off.

If you have a gui (such as gnome), you can do this fairly easily in the system’s settings.