Installing Error

I want to try rocky linux but after i downloaded the DVD x86 version it shows me to choose
If i want to troubleshoot or install. I choose install it shows as if starts to do something and goes to black. Also tried the gnome version of 8.5 and exact same issue (im starting on linux so maybe i am doing something wrong)

1 Like

OK a few things come to mind: Did you check sha-whatever to see if it copied correctly?

Second, I assume you downloaded the DVD_x86.iso file. While it says “DVD” it will NOT fit on a standard DVD or even a 2X DVD it needs to be copied to a thumb drive, and installed from the thumb drive.

Third it is frequently a good idea to simply run the “troubleshoot and install” rather than jump into a straight install. The troubleshoot will usually catch any corrupt files.

Assuming everything checks out when you do the actual install choose "Desktop + GUI, DO NOT choose “MINIMAL INSTALL” as once you reboot it will drop you into a MINIMAL INSTALL ie a Konsole.

When you choose Desktop + GUI (or whatever it is) the GUI you will get by default WILL BE GNOME. If you go hacking or know someone you can load a lot more DE such as KDE, Xfce, Cinnamon, MATE, and a few others. I usually load at a minimum both KDE and GNOME (partially because I use KDE) but also if things go south during login you can try an alternate DE other than your preferred one. If you still have problems, that means something is really screwed up; if not, it usually means that the problem may be within you config files.

In the instant case go back to the beginning and make sure you downloaded a CLEAN COPY of the DVD_x86.iso, and make sure you copied it to a new or unused thumb drive, then make sure that the thumb drive is the first thing that is loaded by BIOS. During the actual install DO NOT choose “Minimal Install”, but either Desktop or Server + GUI .

If you are really having trouble with the install (Anaconda can be a bitch) see if you can find someone from a local LUG give you a hand.

Hope this helps.

D’ Cat

I think you mean “test media and install”

1 Like

I tried everything and nothing worked, so i went to the archives versions and downloaded de 8.4 then updated

Thanks for the catch. My brain is mush sometimes.

D’ Cat

?!?!? NOTHING WORKED?!?!? Did you get RL 8.4 installed?!? When you “updated” the machine I assume you are now in RL 8.5?!? Yeah, I’ve had to “backdoor” my way in to CentOS, and RL a few times.

Please let us know how your experiment went. I’m “Curious”

D’ Cat

I mean, i tried everything from the actual 8.5 and didn’t work. But the 8.4 worked perfectly fine and updated with no issue

Now I am REALLY CONFUSED: Let’s see if I got this right:

  1. You downloaded RL 8.4
  2. You Updated RL 8.4

IF you updated RL 8.4 THEN RL 8.4 SHOULD have automatically ROLLOVERED to RL 8.5. The AUTOMATIC ROLLOVER has been a feature since RHEL and CentOS 7.4.

To check what you are actually running you can check /etc/@redhat-releasse, /etc/rl–release, or /etc /rl-release-upstream. IF I remember correctly (I am currently in openSUSE 15.3 Leap).

An alternate way is to use an very handy utility that everyone should have installed called inxi. Then just run inxi -xxx -S Depending on what options you include it can give you a boatload of information about your computer… plus the weather!!

IF you downloaded RL 8.4 AND updated it as you say then you SHOULD be running RL 8.5.

It seems that @SvelteCone has prepared two install-media: one 8.4-based and another 8.5-based.

  • The 8.4-based installer appears to function perfectly and then system can be updated quite normally to 8.5-based content
  • The 8.5-based installer fails due to something. Either the preparation had a flaw or the installer has changed in 8.5 in a way that on SvelteCone’s system reveals regression.
1 Like

Nono. The problem was fixed by updating. The iisie that i had was only on the 8.5 and i was sharing the olution i had, this being installing through 8.4 and updating

jlehtone You came to the same conclusion I did: He downloaded 8.4 which worked puuurrrfectly and then updated 8.4, meaning he is running 8.5 now due to the updating. That said I get the impression – right or wrong – that AFTER updating 8.4 he still thinks he is running 8.4 [SHRUG] Oh well. If it is running purrrfectly for him – whatever he is running – that is all that matters

D’ Cat

Nono the issue is ,kind of, resolve i am on 8.5 and working fine but i was asking before i resolved it lol

Yes, you did get a functional system.

However, we do not know what was the actual problem with 8.5-based install media.
Perhaps it was just in your pendrive and shall not be encountered again, which would be great.

If it was the combination of 8.5’s installer and your hardware, then it is possible that someone else with same hardware will encounter the same issue. In that case it would be nice to already know why things go as they go. (Digging up ancient installer image is not a sustainable solution to offer everybody.)

I thought of that but i didn’t have any other flash drive around (i bought that one just to switch to linux) im gonna see if someone borrows me one and try

SvelteCone You can usually buy a pack of 2-3, depending on size, from $10-$20 at Walmart, or online from some place like Amazon for about the same price. They are the most handy things to have on hand. They are the modern version of “Sneaker Net” (which goes back to the days of Floppy Disks), though SSH may or may not be faster. Having files on a thumb drive has its advantages. I usually have 2-3 16-GB Brand New Thumb drives somewhere. They are great for doing BIOS Updates etc. You can also buy 32 GB, 64 GB , and 120 GB Thumb Drives as well – they are particularly handy for creating a “Computer on a Stick” – you have someone who wrings their hands over their beloved “Windows XY” , you can plug in your “Computer on a Stick”, and boot into Linux, do your thing, and exit without toughing their “beloved Windows”. Small enough to fit into any pocket or even a key-ring. When I travel I usually have 2 COS: 1 is the latest version of KNOPPIX – A GREAT utility program to have on hand, and the other being CentOS (now RL or openSUSE 15.3).

Best Fishes,
D’ Cat

So i finally found a store that had thumb drives (yes where i live there wasnt one) an no i had the same issue. But i did try with alma and had the same issue so it can be either mi pc or rhel since it’s basically what rocky and alma are (im new so maybe it’s nothing to do )

Really don’t know why, but i turned the safety settings on in the bios and it worked so i guess this can maybe help some one