Rocky Linux 9.0 connects but does not download

I just installed Rocky, and when I try to download a file, it stays connected but does not download; I am using wget, I have also tried curl, and it is the same. (see image)

When I try from a centos, on the same network, it does download without problems.

Can someone please help me?

Installed it to what?

If the machine has GUI, are you able to use a web browser, and does it work?

My computer has no GUI, it is a server to install an Atlassian application called Jira.

OK, so it’s a real server that only allows text based interaction.

Have you done basic network tests, for example within your network, and also things like ICMP to and from external, e.g. ‘’, tested DNS resolver etc?

Can you also run

nmcli device status
nmcli connection show

you can paste plain text into the forum, you don’t need to do screenshots.

Internet I do have, the server can reach the destination on the internet but cannot download.

[root@server jira-install]# nmcli device status
ens192  ethernet  connected  ens192
lo      loopback  unmanaged  --
[root@server jira-install]# nmcli connection show
NAME    UUID                                  TYPE      DEVICE
ens192  91d9d69f-0467-3edb-8e94-748e8edc0685  ethernet  ens192
[root@server jira-install]# ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=117 time=7.61 ms
--- ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 7.608/7.608/7.608/0.000 ms

Is it new hardware? 12th gen Intel?
At least some versions of Intel NICs on that chipset do have a bug on 9.0’s kernel. Apparently fixed on 9.1.

I got one such machine recently, installed (AlmaLinux) 9.0 and did hit the bug hard.
As temporary solution I did install kernel-ml packages from ELRepo’s ‘elrepo-kernel’ repository.

lspci -nn | grep -i net shows network devices and their Device ID.

is a virtual machine that is in a VMware hyperconvergence.
I just installed another machine with Rocky version 8.7 and the problem is the same.

[root@server ~]# lspci -nn | grep -i net
0b:00.0 Ethernet controller [0200]: VMware VMXNET3 Ethernet Controller [15ad:07b0] (rev 01)

el9 has driver ‘vmxnet3’ – VMware vmxnet3 virtual NIC driver – for device 15ad:07b0.

Nevertheless, the issue is probably VMware–el9 compatibility. I don’t use VMware, so can’t help.

I have had problems in VMware with vmxnet3 driver, on Debian even just running apt-get update caused the server to restart. Add a network card, but instead of vmxnet3 use Intel Pro 1000E instead (or whatever E1000 shows up on the list). You cannot edit the existing card to change it, so have to remove it and add again and change the type when adding. See how you go with that.

I did what you tell me and the problem continues, I returned it to the vmxnet3 and I have noticed that it works at times, for now I will only continue to use this operating system for testing, I will not put it in production because I’m a little scared that it will not work properly.

What version of VMware are you running? I’m running 7.0.3 and Rocky 9 works fine on it with vmxnet3.

I’m running version 6.7

What template did you use for the machine when you created it? RHEL9? Or some other template/machine type?

I downloaded the Rocky iso from the official site and then uploaded it to my VMware and installed it step by step, without template.
Do you recommend a better way to do it?

Normally when you create a VM, you have to choose a Guest OS Family and Guest OS Version. So did you choose Linux here and then RHEL9? Or something else?

I chose this option:

I tried Rocky 9 and when I saw that the navigation was not working properly, I installed Rocky 8.7, but the problem is the same.

Are you able to wget anything else (other than atlatssian) successfully on this rocky9 machine?

Hi, I have decided not to continue working with Rocky for now, as I need to keep moving forward with the project, in the future I will give it the opportunity again hoping that this kind of problems will not happen to me again.
thank you all for your help!