Greetings fellow rocky linux users!

I am such a networking newb. I already set up my server running Rocky Linux, and it is connected to my router and laptop. I’m having trouble making the connection though. Like I said, this is my first time, and I thought since I’m using Rocky Linux, I should post my question here. It isn’t quite RL specific, but computer related in general.

1 Like

Hi and welcome,

What is the server set up to do?

How are you trying to connect to the server?

Thanks Tom.

  1. Many things at once. Everything from home automation to just a machine to tinker with.

  2. I have ethernet cables connecting my laptop, server and router with a switch. Short answer is that I want to be able to use my server from my laptop without the extra monitor, mouse and keyboard.


You can try connecting via ssh:

If you prefer the gui, you can try VNC:

Thanks Tom.

Odd that there is “How to enable SSH” considering that even the minimal install includes group ‘core’:

# dnf -q group info minimal-environment
Environment Group: Minimal Install
 Description: Basic functionality.
 Mandatory Groups:
 Optional Groups:
   Guest Agents

… the group core includes package openssh-server:

# dnf -q repoquery --groupmember openssh-server

… and the service is enabled by default (vendor preset):

# systemctl status sshd | head -2
● sshd.service - OpenSSH server daemon
   Loaded: loaded (/usr/lib/systemd/system/sshd.service; enabled; vendor preset: enabled)

In other words: I don’t recall any RHL/Fedora/CentOS/RHEL install where the sshd.service was not up and running from start. (Except perhaps last millenia.)

Your router most likely runs DHCP server and both your server and laptop ought to use DHCP client to get network configuration.

It is possible, if you did minimal install from local media (pendrive) that network connection was defined, but not set to start on boot. What do you get when you run nmcli on the Rocky?

If your router allows “static map” / “bind MAC” in DHCP, then use it so that the server (MAC address) will always get the same, known IP address. You need to know the address when you connect (e.g. with ssh).

1 Like

Thank you Tom and jlehtone. I will try the CLI route first, then GUI if I need some convenience. Speaking of GUI, I did manage to install XFCE! :smiley:

P.S. Please disregard my deleted post, I’ll find a way around that issue.

1 Like