Rocky Installs keep freezing mid-process

I’m attempting to work on my RHCSA, and trying to install either Rocky or CentOS onto a beater desktop to practice upon.

However, I am experiencing an inability to install Rocky versions or CentOS 7 version to system, as process keeps freezing during either testing, or initial installation process.

  1. Downloaded Rocky version 9.iso file - scanned for to confirm non-virus infection, then checked and confirmed signature.
  2. Installed said .iso file with Rufus.
  3. Rebooted system to commence installation.
  4. Tested the .iso file, when I rebooted the system: testing process stops with either these two messages.

“Starting Load/Save RF Kill Switch Status”
“Starting Load/Save RF Kill Switch Status of rfkill0.”

Checked the installs of
Rocky 9,
Rocky 8, and
CentOS 7 on other computer systems: all of the computer systems completed the process to reach the installation GUI.

Reset BIOS to default, wiped the hard drive with “Darik’s Boot and Nuke - DBAN,” ( and re-attempted the process: process stopped again at the "Starting Load/Save RF Kill Switch Status.

Attempted install of OS instances with balenaetcher, to re-attempt the steps above: same result experienced.

System is an HP system, I5 CPU, 16GB Ram, 1TB HD.

Checked online for error messages - found this link:
Error seems to indicate that the issue has been resolved - but, apparently, that is not the case.

Haven’t run into this before.

I reviewed your Bugzilla link, and did a big of searching. My only recommendation would be to make sure you’re installing using the latest Rocky 9.1 ISO, just in case whatever bug is causing this has been fixed.

This is just a guess, but “RF kill switch” sounds like it might be related to wifi on the system. It might be worth a try to temporarily disable or disconnect whatever device is providing wifi to your computer, and see if the install completes.

Once you’re able to install the OS and install all patches using ethernet, I’d be curious whether the issue keeps happening if the wifi hardware gets re-enabled.

1 Like

Not sure how to disable to wifi when I wiped the hard drive.
Also, I might have been imprecise in my original description. The installs that I attempted (Rocky 9, 8, and CentOS 7) worked on other systems (whether I used the “test” option, or “install” option) - but, those same installs didn’t work on the target system - with the same result experienced both before and after wiping the hard drive).

Yeah that’s a tough one. Depends on what computer you’re using.

My laptop for example has a setting to disable wifi in the BIOS, but this tends to only be an option on computers sold to businesses.

If you’re using a desktop computer, and there’s no option to disable wifi in your BIOS, opening the case and physically disconnecting the wifi card might be the only way to do this.

I feel like we might be getting distracted and solving the wrong problem here though.

If your goal is to run RHCSA labs and you don’t have spare hardware that’s compatible, you might be able to instead install Rocky as a virtual machine on another computer.

Rocky runs great as a virtualized guest under HyperV, Proxmox, or Virtualbox for example.

Oh, no - the installation is the main problem upon which I am focused (I guess one could argue that this has become personal for me). I’ve been able to successfully run this on Virtualbox without an issue - but I am curious about what is causing this specific physical system to reject the installation (even when other systems take the same installation USB without an issue).

I just mentioned the part about me studying for the RHCSA to illustrate that I am still learning this stuff.

" 2. Installed said .iso file with Rufus."

PSST. Rufus is NOT your friend. Use the dd command. There has been a lot written about why you should NOT use Rufus but should use the dd command . I suspect the this might be at least one reason for your problems.

D’ Cat

My issue with that is that my other systems are Windows based - do you recommend a dd utility for Windows?

Otherwise; I’ll try to create a virtual Rocky server, to use its dd utility from there.

Mind linking the articles mentioning issues with Rufus?

Are there any issues mentioned with the other application used (balenaetcher)?