Rocky Installer Does Not See Hard Drives


Our Dell PE R620 server has a PERC H710P Mini controller. We followed the procedure to flash it with generic IT mode firmware and all went well. No errors, and I had no trouble re-programming the address back into the card.

The server has 6 x 2TB Samsung SSD drives in it. After reboot, the BIOS sees all the drives, but when I try to install Rocky Linux, it does not see any drives, even when I specify the correct mpt3sas driver during install. For example, adding the following boot-time parameters…


The boot procedure downloads the driver just fine and loads the kmod-mpt3sas module without complaint, but then the installer still shows “no disks detected.”


That is really odd. How did you determine that mpt3sas is the right driver for your device? I believe it is correct but just to make sure …

HUMMMMMM. Kind of odd. My luck with things made by “Dell from Hell” is batting ZERO, so from a skeptic’s point this should not be a surprise, still… One thing you could TRY is to use something like KNOPPIX 9.1, and first bring up fdisk -l to see if fdisk can find the drives (it should). Now IF you have some old beater drive laying around somewhere, connect it and then in KNOPPIX 9.1 there is a handy utility called GParted. Go into GParted and erase (wipe) the entire drive and save the changes. You now have a CLEAN drive to experiment with. Now do the install again. At a bare minimum I would expect the install to find your CLEAN drive; if it does NOT find that clean drive then either your copy of RL 8.6 is BAD (do a check of the SHA-256 and see if it matches, if not you have a corrupted download) or something on the mobo may be BAD (not unheard of with DELL computers), or finally maybe when you FLASHED the Firmware you either updated it beyond what the OS can deal with, or partially bricked the system.

There is a final thing to consider: GRUB2. RHEL 8.6 and its children puts /boot/loader/entries, rather than under /boot/grub2.

A final thing you could try is to do an install of something like Fedora XY which I think uses the exact same installer as RHEL (and its children) , or do an install of something like openSUSE 15.3 (or now maybe 15.4) Leap.

The purpose of these experiments is to narrow down the cause to see if you have a HARDWARE PROBLEM or a SOFTWARE PROBLEM. The CLEAN ol’ beater of a drive will help you determine what the nature of the problem is (besides it does not work),

D’ Cat

Well, I think I sort of resolved it by accident. I tried installing Windows Server 2019, and Windows did see a couple of the drives. After installation, I brought up Disk Management, which showed the other drives as present but “offline.” I right-clicked each drive and forced it online. Then I rebooted and tried installing Rocky again, and it could then see the drives during installation. I dunno, weird, but at least I got Rocky installed. It’s unfortunate that the Rocky installer does not let you shell out or I could have probably resolved the issue without so much fuss.

I think it does let you shell out, but it’s not a good idea because it can confuse the installer.

SOLVED! It turns out that the drives had previously been part of a RAID set. The Rocky installer refused to show them because they still contained a RAID signature. I force-wiped them and then the Rocky installer showed them all. I duplicated the same behavior on another server.

That reminds me of one time I transferred a RAID-1 pair from fakeRAID NVidia chip to fakeRAID LSI chip (on another motherboard). Linux dmraid could not care less, it did happily continue to enable and use the “NVidia array”.

It is fascinating that PERC array metadata is handled/reacted to too.

The installer does have a console where one can run CLI commands. I recall creating partitioning there when installer’s GUI had no support for it (CentOS 5?). However, are there tools to modify PERC? The DELL utility in firmware is safer bet for that “wipe”.

I’m not sure the PERC commands still apply because I flashed the card with 2308 IT firmware. Now it’s just a standard LSI 9207-8i non-RAID controller.

Congratulations. When you said you had 6 2 TB drives I was wondering if you had them set up in a RAID array or something like that, one of the reasons I was “curious” what would happen if you erased and stuck in a CLEANED drive what would happen.


D’ Cat