Unable to detect logical raid drive on HP Proliant DL360G5 during installation

Hi. I am trying to install Rocky 8.9 on some older hardware.

lspci -nn
shows
HP Smart Array Controller [103c:3230]

I tried to load sg, hpsa, hpsa.hpsa_allow_any=1 hpsa.hpsa_simple_mode=1

Still no cigar in showing any disks to perform an installation on a logical raid drive. I have even attempted to remove the logical drive altogether and it still does not see any disks.

modprobe -c | grep -I 103c shows hpsa, hpwdt, hilo, bnx2, bcma, ath9k, aacraid, smartpqi, snd_usb_audio and rt18192cu but I don’t think I see anything specifically for 103c:3230?

Any idea on what to do here? Is it feasible to get these drives to show to perform an installation. I plan to eventually PXE boot these guys using iSCSI but I’m still interested in why Rocky8 is not detecting these drives.

Thanks for any help!

I seem to have found it here as kmod-hpsa
https://elrepo.org/wiki/doku.php?id=deviceids

How do I install this during installation and ensure it is loaded during boot?

Yes this seems to be quite the conundrum. I seem to be unable to install EPEL during the installation process. Is there an image that contains epel usable modules during installation process? dnf config-manager is not installed. If I try to install epel.org using start [ELRepo Wiki] I get an error. What is anaconda anyways? Doesn’t seem to be a real live image. Newb here. Thanks!

If Rocky is not installed yet, how were you able to run lspci? Did you boot install media, and then request a prompt instead of installing it?

Can you try
lspci -v -d "103c:*:*"

Are you planning to put Rocky onto the RAID, or is the RAID for data only (if so, you might not need the driver during install - do it later?)

Yep install media. Similar commands to go to lower init level in Linux. Ctrl shift f2 I think. Then you get tmux and other terminal to run commands. I’m not sure what sane person would not use raid for a persistent service node. Even snapshots results in data loss albeit usually only OS related. But in the end I have a proposed solution worked out I will test later after discussing on the Mattermost channel. I also plan later to just pxe boot from a iSCSI interface and not use local storage at all. Just playground for me atm for updating old 10Gbps pcie firmware. cheers.

For those who may come across this issue here is the solution.

Download your required dud here (Index of /linux/dud/el8/x86_64) and burn it to another USB (the same way you wrote your installer on a USB). In my case the dud required is hpsa (https://elrepo.org/linux/dud/el8/x86_64/dd-hpsa-3.4.20-9.el8_8.elrepo.iso).

Insert both USB sticks into the device you’re trying to boot from and voila.

And for me it just picked it up. You’ll see it mount the USB etc in the boot of the installer.

Then like some sort of magic it shows up. If anyone knows precisely how this works I’m curious. But for me research for another day. Onto the project.

Look at the last post in the following link for reference.

reference: centos 8, DL380 G5, P400 - Hewlett Packard Enterprise Community

reference: The ELRepo Blog: RHEL 8.0 and support for removed adapters

reference: Chapter 17. Boot options Red Hat Enterprise Linux 8 | Red Hat Customer Portal

1 Like

Make sure you install elrepo-release so that the driver gets updated when needed.

1 Like

You don’t need second USB if your network is operational; then the installer can download for you:

inst.dd=https://elrepo.org/linux/dud/el8/x86_64/dd-hpsa-3.4.20-9.el8_8.elrepo.iso

Thanks. Yes that could work. I noticed I had to activate my network card after in the installer. Not sure if it would auto activate or some incantation would enable on boot to do the download as I haven’t tried it. But for me less typing just using a second USB. Especially if imaging a few nodes. I’ll eventually graduate to PXE once my storage and boot system are operational. Cheers