RockyLinux install on OptiPlex 740 not showing SATA HDD

I am attempting to install RockyLinux 8.8 on a Dell OptiPlex 740. It was originally running Windows 10 on an HDD with the bios version 2.6. I upgraded the bios to the latest 2.8, turned off fastboot, checked to see that RAID mode was off, and changed the boot order to start with a USB. Used rufus to create a USB of the live Rocky 8.8 image, started up my computer, and everything was working fine except there are no drives visible for install. I tried other (known working) HDDs, reformatted them, turned on RAID mode, tried HDDs that already have rocky8.8 installed, none of them are visible in the install window. Anything I plug into a USB port is visible. Any ideas?

One thought is that the hdd is using the GPT partition layout and in the rocky installer you somehow chose msdos/legacy install. In that case no usable media would be found. You might be able to confirm this by selecting the custom partitioning option and also selecting the blivet disk utility. I may be wrong but getting to the blivet partition utility should see the disk assuming that it is seen in your bios/firmware.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.