Rocky 9.2 Cannot Disable nouveau Video Driver


I have installed Rocky 9.2 on a circa 2010ish generic PC. The machine has an I7-990x, 24GB RAM and NVIDIA GeForce GTX 980 video card. The purpose of this machine is to run Blackmagic Design’s Davinci Resolve Studio and it will not run with Nouveau.

I have been unsuccessful installing the video driver “”. Even though I’m booting to the shell as “root” The installer sees Nouveau running and fails. I used it to create the file: nvidia-installer-disable-nouveau.conf with which contains;
→ blacklist nouveau
→ options nouveau modeset=0
It then saved it in the directores /usr/lib/modprobe.d & /etc/modprobe.d

Alas, after rebooting this has not stopped Nouveau from loading. I’m still getting small 1080HD sized characters on the shell screen not the big segmented stuff you get with a VGA.

So how do I turn Nouveau off?

Any help in pointing me to the correct solution, documents, ELRepo resources would be much appreciated.

strong text

NVidia has their own repo with RPM packages.

$ cat /etc/yum.repos.d/cuda-rhel9.repo
baseurl =
enabled = 0
gpgcheck = 1
gpgkey =
name = cuda-rhel9-x86_64

The packages should have a better chance to “install correctly” than the unmanaged binary.

You should also add module_blacklist=nouveau to the kernel cmdline …

@Ritov - I found your earlier 2021 post regarding this with the commands to rebuild modules and grub config and that worked for me. I was able to install the Nivida driver after installing a couple of dependencies and my system worked great. I’m new to Linux and your tip made me do a bit of digging and I learned quite a bit. Thank you

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.