RAID Installation Drivers Problem

Need some help here with driver install at boot installation. I recently bought a Dell Poweredge 2950 circa 2007, currently with RAID 5 and the PERC 5/i RAID controller.

It currently has a Debian based distro installed. I really need a Red Hat based distro server OS though. The 6 Cheetah SCSI hard drives wont show up when booting for install. When I use the three methods outlined in the Installation Manual they do not work.

I tried;

11.2.1. Automatic Driver Update (Volume label OEMDRV and just straight booting Anaconda without any command line input)
11.2.2. Assisted Driver Update (Same as above except using the <inst.dd> with no arguments at the command line)
11.2.3. Manual Driver Update (Same as above but specifying location, i.e. <inst.dd=location> example /dev/sda or sdb)

The CD rom drive does not work and there is no floppy drive. I thought it was strange that it did not have a DVD drive instead of a CD drive. I tried something off the wall, I made a single USB drive with two partitions, one with the Rocky bootable iso, the other partition with label OEMDRV with the drivers. No good either. Some years ago Red Hat stopped putting these drivers for these older servers in their ISO’s and so [] sought to bring them back. I used the DUD [dd-megaraid_sas-18192-x86_64.iso] from the Elrepo site.

As per the RHEL installation guide on page 48, I tried extracting the ISO image for automatic recognition and I tried just copying the ISO image for manual installation. No such luck. It wont recognize the driver USB. I cant even get to the screen that tells me to select any drivers or anything. Anaconda shows no HD’s.

I also read and followed the discussion thread here [] without any luck. I’ve tried these methods on other RH based distro’s Alma as well, CentOS, Oracle also. But it’s a RH i.e. Anaconda thing. I do not know what I’m doing wrong. I’ve searched the net for 2 weeks without any fix. Any help suggestions greatly appreciated. Thx.

Does the installer have functional network driver?

The <inst.dd=location> can have an URL as location.

Where did you see such a DUD file?? Anyway, if you are installing Rocky-8, you’ll find the DUDs here:

and Rocky-9:

Make sure your release version matches the elX tag. For example, if you are installing Rocky -9.1, find the one with the .el9_1.elrepo.

Note on Rocky 9. It does require x86-64-v2 microarchitecture from the CPU and
first such Intel CPUs appeared around 2009. The first “Dell 2950” specs that I did
find say that that Poweredge had “Clovertown” or “Woodcrest” CPUs – released 2006–2007.

One can check in Debian whether the CPU supports x86-64-v2: cpu architecture - How do I check if my CPU supports x86-64-v2? - Unix & Linux Stack Exchange
If not, then Rocky 9 is not an option.

1 Like

Good catch. Go for Ricky 8 then.

I have version 8 RHEL. My bad. The [dd-megaraid_sas-18192-x86_64.iso] actually came from Dell’s website, as they said that was the correct driver for the 2950 and Perc 5/i controller. However I did try the 8-ver. from elrepo site. Since I did not know which one I just put all of them labeled “dd-megaraid-sas” on the USB drive labeled OEMDRV. It still failed to get to the screen to choose a specific driver as outlined in page 4 of [ ]. It’s supposed to take you to a screen to choose a specific driver. I never get to that screen. The guy that started the thread on the Red Hat forum that I linked to produced a video detailing how he worked this out from this link [The ELRepo Blog: RHEL 8.0 and support for removed adapters] I downloaded the video and cannot produce the same results. Even if I have the wrong driver, there should still be presented a screen to choose drivers from on the DUD. If that is not the case and the whole thing hinges on having the correct driver then can you tell me what the correct driver is on elrepo or elswhere? It is a Dell Poweredge 2950 with a Perc 5/i RAID controller.

The video you tried is the best tutorial I’ve ever seen. I don’t know why it did not work for you. But anyway, if you have network connection during the installation, you can use a URL as @jlehtone suggested. For example,


This is assuming you are installing EL 8.7 and your driver is megaraid_sas.

I put my USB WIFI adapter in and boot but it does not seem to connect to net with the Dell server. I also tried the USB DUD method on another machine entirely ( a Dell Optiplex) and I still never reached the driver selection screen. I just don’t know.

I was reading a different manual from another Red Hat distro maker and it said to put the DUD in only after the system has booted and reached the GRUB menu. I’ve never heard of that. I will try it. I was always booting up with the DUD already plugged in.

Since this is looking like an epic fail I may have to resort to another method. I ran across a document titled “Red Hat Enterprise Linux 8 Composing a customized RHEL system image”. I can supposedly make my own bootable media and perhaps put the drivers in it so that no DUD is needed. How hard is this? I’m kind of a noob but I have the instructions. Can I put the drivers in it?

Forget it. That’s not going to work either.