Driver for Broadcom BCM5709 Not installed

Hi, we’re about ready to finally migrate to Rocky Linux 9 and I got the go ahead to start imaging some render machines. We have 81 Dell R610s and there isn’t native support for the Perc 6/i RAID controller or the BCM5709 NIC in the image. I figured out how to get the RAID driver installed using a DUD from elrepo and hosting it on a foreman repository.

Now I have to figure out where to get the driver for the NIC. During PXE networking works, but after it’s actually imaged and kickstart finishes no driver is installed, so I have a Rocky Linux 9 machine without network connectivity. This should be simpler and all I need is a compatible RPM that can be installed in %post at the end of the kickstart installation.

I ran lspci -nn and got the vendor device id: 14e4:1639, but I’m not finding this on elrepo and Dell doesn’t have support for anything beyond RHEL7 as far as I can tell and I didn’t see anything from Broadcom. Can anyone point me to a compatible driver package? I got a bundle off the internet that included a netxtreme2 noarch and a bnx2i noarch package which I tried but without success. The troubleshooting is complicated by the fact I’m remote and there are only iDrac express on these so I can’t see what is happening during install. I’ve been asking teammates to check for me.

If all else fails, I’d be willing to try my hand at compiling source code on one of the R610s and using the RPM for all other machines if someone can point me to where I can get that.

Thanks in advance.

According to this: removal of SAS-2 controller drivers in RHEL 8 - Red Hat Customer Portal support was removed from RHEL9. There are posts that say despite the warnings in RHEL8 that support will be removed, the cards do work.

Have you tried installing Rocky 8 on these machines? You could ask if elrepo could package this if they don’t already have a package for EL9. Otherwise, you might be stuck with Rocky 8 for now if there isn’t any success with Rocky 9.

Another option might be to use the kernel-lt or kernel-ml from elrepo, since these might have the modules you need. Perhaps you could install them during kickstart.

Device 14e4:1639 is supported by the bnx2 kernel module and it is included in the distro (Rocky 9) kernel. So I don’t quite understand why it does not work. What do you see with a “modinfo bnx2” ?

Thanks, we’ve been testing for months on Rocky 9, so we’re not going to go back to 8. But thanks for the feedback. Worst case scenario I imagine we could buy 81 PCIEx1 NIC adapters and fire them in.

I don’t see anything as it’s the weekend and I don’t have the ability to remote console :slightly_smiling_face: It’s a shame they didn’t invest in Enterprise iDracs, but it is what it is.

I think I’m going to drive to the office and troubleshoot this on Monday. Too difficult getting my teammates to be remote hands and I’m the only Linux admin. I’ll give the modinfo bnx2 a whirl when I’m on site. Strange that I have network for PXE boot, but a driver fails to install with the image. It’s very frustrating doing this blind, but I’m happy with the progress I made for the RAID controller on Friday. I’m sure this is solvable.

Update: Redhat’s position is that BCM5709 should no longer be used in production and is “unmaintained”. While it may still be in the image, perhaps it’s not very reliable.

modprobe bnx2 returns not found. I tried modprobe bnx2x and that returned a verbose error, but when I went to the /var/lib/ kernel module path it’s not there.

That is odd. What is your kernel version? Please show us the output from:

$ uname -r

$ find /lib/modules -name bnx2.ko.xz

1 Like

Thanks for the help guys.

Your mentioning that it should be included with the image gave me a clue. I had my foreman repo that was mirroring baseos set to “on demand” which only pulls down packages as needed. I guess the process of how the network driver is installed wasn’t triggering that maybe? I set the baseos repo for Rocky 9 and Rocky 9.3 to a complete sync and now it appears to be good. Very weird problem. My frugality in downloading packages bit me in the behind I guess.

Kudos for all the replies.