Qt File Picker in GNOME is Dysfunctional

Apparently Wireshark is Qt only now?

Trying to open a file in Wireshark in a GNOME desktop is annoyingly difficult. The size of the dialog changes erratically. It’s initial state is too small. It resets to this initial state each time it is opened. This means resizing it manually, changing columns each and every time …

Is there any way to improve this situation?

Is there any way to coerce Wireshark to use the GNOME file picker?

Hi, I’m not sure I understand your problem. From the screenshot below, Wireshark in Rocky 9 looks perfectly fine to me. The size is also exactly the same every time I launch it, and if I maximise it, and close it, it still launches maximised without problem. Maybe you can explain better or perhaps show a screenshots?

on my system I just did:

dnf install wireshark

and this package comes from appstream repository. Doesn’t look like QT to me anyway, seems to have a Gnome-feel to it.

That’s not my experience. It does not remember the size at all. Window manipulation behavior is erratic. For example, I just tried to grab the right edge and drag it wider but it suddenly snapped into a narrow window:

I could not actually make this narrow window wider using the right edge. I had to grab it by the lower right corner and then it suddenly snaped back into it’s previous size. Just strange.

My Rocky 9.2 install is mostly stock. I did add the epel repo. I installed Tweaks just to set Appearance > Themes > Applications > Adwaita-dark.

I installed wireshark exactly as you did and it looks like it’s using Qt:

# rpm -q wireshark --requires | grep Qt

From Googling around it sounds like the Wireshark folks are using Qt exclusively now for cross platform reasons.

It does not react to windowing commands like Windows+Left and it looks nothing like the standard GNOME picker:

Can you disable tweaks and see how Wireshark works then. My install does not have tweaks installed, and Wireshark behaves normally.

I tried disabling Tweaks > Windows > Attach Modal Dialogs and Tweaks > General > Animations. No change.

And if you create a new user on your system and login as that new user and run Wireshark? Just to check/test a completely clean desktop environment with no tweaking etc or something that may have introduced it to an existing profile?

Good idea. I shutdown, disconnected the external display and USB leaving nothing but power and network. Booted, went into a different pristine user and tried Wireshark. Again, the file picker size would reset every time I opened it.

Also, I tried to open a file that was not a pcap and got an additional modal dialog that just read "The file … is not a capture file … OK but clicking on OK did nothing. I had to select Wireshark > Quit from the desktop banner. That closed the modal and the picker but not Wireshark. I had to select Wireshark > Quit again to close Wireshark completely.

So it seems the picker is maybe a separate process and it’s missing some linkage.

I also tried X11 instead of Wayland. No change.