PowerEdge Expandable RAID Controller unsupported?

For initial testing, I tried to install Rocky 8.4 on an old PowerEdge 2950 equipped with a PowerEdge Expandable RAID Controller. The install was unable to detect any disks. Am I correct in thinking that Rocky 8.4 does not support the PowerEdge Expandable RAID Controller?

1 Like

Could it be that this is an old MegaRAID controller? Because I also had that problem with my IBM system, in that case you can go over to ELrepo and grab the correct DUD ISO which then provides the firmware.

This is due to the drop of the firmware from the upstream side, so it won’t be fixed in Rocky Linux if it isn’t available in RHEL anymore :slightly_smiling_face:

That was indeed the problem. I was unaware that those drivers had been removed from RHEL 8, and thank you for providing that very helpful link. Following their instructions, I was able to get Rocky installed, and I look forward to trying it out. Thanks again.

Okay perfect!
Good to hear that you found the stuff there which was needed :slight_smile:
Yeah there was a lot of hardware cleanup with RHEL 8, but fortunately there is ELrepo.

You’re welcome!

I have this same problem… can I add the driver to the same USB Drive I am using for the instalation and have the installer find it there?


A DUD is always a separate drive unfortunately, this gets discovered by the LABEL of the drive :slight_smile:

But if you would like to look into patching the installation image (the firmware is in the elrepo), you might also get it working with one drive, the easier way is definitely the DUD

I tried installing on Del Poweredge R610 and Raid not detatcted. Any solution?

I would recommend anyone here to use elrepo for hardware that was dropped in EL8. DUD’s are provided as well as the necessary repos that provide the kmods needed.