New to Rocky - Won't Boot from USB

Hello,

I am new to Rocky Linux. I have used Rufus, Unetbootin, Linux Mint’s built-in bootable USB creation utility and DD from the terminal in order to boot from the USB.

The image I am using is the dvd1.iso. I have run the checksum and all is OK with the image.

Unfortunately, I cannot boot from the USB in order to install the OS.

This is the message I get when trying to boot from USB:

Invalid image
Failed to read header: Unsupported
Failed to load image: Unsupported
start_image() returned Unsupported

The hardware in question is an HP ProDesk 600 G1 TWR.
Intel Core i5-4570 CPU
Nvidia GTX 730 (Gigabyte) GPU.

I’m not sure if the problem is hardware related or if the bootable USB isn’t created correctly.

I have installed Linux Mint and other Arch derivatives on the same machine. It is currently running Mint with which I tried to create multiple bootable USBs using different methods.

I always get the same error.

Hi @netstrider ,

sorry to read you’re having trouble.
In a nutshell, there is nothing special that needs to be done with regards to image writing, or that is different from other ISOs / distros and the one of RockyLinux.

From your description, I understand that you seem to have experience in creating bootable USB media from downloaded ISOs. So, first question: Are you using the correct image (in the sense of architecture: the x86_64) that is available at

https://download.rockylinux.org/pub/rocky/8/isos/x86_64/Rocky-8.5-x86_64-dvd1.iso

If yes, then next question is:
Did you check your USB media (thumb drive, I assume) is ok?
Perhaps it makes sense to try writing onto a different USB media to check if that makes a difference?

Finally, you could try to use Balena Etcher to write the image to USB.
I found this to be the only image writer that works for me in all scenarios, regardless what kind of ISO to “flash”. I have seen rufus, unetbootin et.al. to increasingly fail to work correctly with contemporary ISO files. Might be just me, but probably worth a try if all else fails. It’s available at

Cheers, hope this helps (sorry if not), Thomas

Hello @schroedingersdog

Thank you for your suggestions. I can confirm I have the x86_64 image.

I have just tried Balena Etcher on a different USB and, unfortunately, the issue persists. I am going to see if the BIOS update from the manufacturer (dated 2017) is newer than what is currently running on this HP machine and see if the update changes anything.

I see no option for EFI/MBR boot options within the BIOS. I think that could perhaps be the problem?

EDIT: Unfortunately it appears I may have to re-install Windows to update the BIOS.

UPDATE: Okay, I did not try the BIOS update. Within the System Utilities, it allowed me to boot any EFI file including grub.EFI, which has successfully launched the installer now as well.

I will update if it all went okay.

EDIT: Installed smoothly and boots fine.

1 Like

Hi @netstrider
I am having the exact same issue with exact same error messages on an HP EliteDesk - but I cannot find System Utilities - is this in the BIOS setup? Or, how do I go to System Utilities? Any help is very much appreciated.

Edit
For future reference for anyone, what I found to work for me is:
Go into BIOS on my HP EliteDesk and go to Security > Secure boot > Legacy support and Enable it.
Now under Storage > Boot order > Legacy boot sources is enabled.