Cannot install 9.1 after burning on flash drive

Hi, I have used rocky linux since 8.3 last year on this same machine. Its a 3930K intel cpu on a msi x79 2011 board from about 2011. Now, I am trying to install rocky 9.1 on the same machine since the old ssd crapped out. Used Rufus, balena etcher to create the usb flash drive but it just wont start installation with the following errors. No matter what selection I made on rufus (gpt on uefi, mbr on uefi/bios and every other combination in between including iso mode, DD mode), it just wont go into install. Not sure how this keeps changing from older installs to newer installs. Any ideas on how to get past this error? I am at my wits end about how to get through here.

Invalid image
Failed to read header: Unsupported
Failed to load image: Unsupported
start_image() returned Unsupported

It seems to work when I tried legacy+uefi, but that stopped working as well. Any surefire way to get this to install. Rocky 8.3 was a uefi install on this machine and it worked the first time. Now it just does not work! Wish there was some consistency in how these are built.


Your CPU likely does not support x86-64-v2. If you still have rocky 8, you can confirm this:

# /lib64/ --help | grep supported
  x86-64-v2 (supported, searched)
  x86_64 (AT_PLATFORM; supported, searched)
  tls (supported, searched)
  x86_64 (supported, searched)

Rocky Linux 9 only supports x86-64-v2 or newer.

Thanks, will try that out and confirm.

@localhost ~]$ /lib64/ --help | grep supported
x86-64-v2 (supported, searched)
x86_64 (AT_PLATFORM; supported, searched)
tls (supported, searched)
x86_64 (supported, searched)

It seems to support it. Checked with both 8.x and now currently on 9.1. I read through some notes on this forum and decided to use ventoy. That fixed the issue of installing 9.1 on this machine. However, the install was in a “legacy+uefi” mode. I am not particularly fond of this boot mode. This pc works with uefi and I would like to install this in a uefi mode to make this boot in uefi mode only.

Thanks for the suggestion. Any input on how I can make this a uefi boot mode only?

What is the output of


It may be that your install media was msdos partitioned and thus required you to enable legacy mode in the boards UEFI to install. Now that all is installed you can switch back to UEFI only.

On second thought this doesn’t make sense since the media should have been Joliet iso format.

Thanks for your suggestion. I think this installed it to mbr. The ssd disk that its installed on is not recognized when I set it to uefi only. There is no /efi partition when it installed it as (legacy+uefi) and I could not create one even if I went with custom partitioning. I kinda knew then that it was setting it up on the mbr. Its a bummer that I had to waste the whole day yesterday trying to figure out why it would not install it in either format. You are not wrong in thinking that the install media was formatted as msdos. Rufus does offer the option to install it to bios+uefi. It also offers gpt for install on a uefi system. I tried both, but it had issues even starting the installation. Such is life :frowning:

But it sounds like your usb image is messed up, not Rocky.
Similar issue here with screenshot:

Well, I fixed it. I guess the problem lay with the EFI firmware on this MSI board. I guess for the most part rufus, balena and ventoy did what they were supposed to do but the damn EFI firmware for this board is freaking BS. This board has always supported UEFI and is backward compatible with the legacy boot (mbr). I tried everything and could not get the installer to launch. The image that was burnt on the usb was fine, but the damn efi firmware on the board looked at the install destination and when it did not find a gpt in there, decided that UEFI cannot go on this disk and crapped out. The firmware should have taken note that the only disk on the system (I had removed all other disks to make sure the installer did not screw up with other disks) did not have a gpt table and had a msdos table and given the user an option to wipe the disk clean and install a gpt table. Instead the board firmware writers decided that it lacked compatibility and threw an error and decided to fly south. So, finally, I wiped the disk clean, removed all old partitions on it, removed the msdos partition table on the disk and used fdisk to create a gpt table, all manually. I did not create any partitions on it, just the gpt table. Then used the same ventoy image from last nite and went UEFI all the way. It works flalessly now. I am guessing since this board is over a decade old and efi was showing up on some of the boards, the firmware did not have enough smarts to figure out all the cracks in the system. What a POS.

Well I just upgraded from rl8.7 to rl9.1 on a mbr disk, parallel install. When I went to make 9.1 the default “grub2-install /def/sda” I had to use the --force option as grub complained the available space was not large enough. This is becoming more prevalent on mbr installs lately. So I’m beginning to prepare to convert this disk to gpt via the gdisk utility. I’ve done it once on a fedora system so I know it can be done live. Timing the install of the grub efi utilities is the critical path.

If it does not start the image, then all bets are off. That was my situation. On slightly newer board where efi firmware is more mature, they do look at these type of issues. Its not that hard for developers to catch such situations. But considering uefi was just showing up back in 2011, it could be blamed for lack of insight. They stopped updating this board in 2012 or '13, so it fell through the cracks somewhere.