8.5 NUC install issue

Hi,

When I try to install 8.5 on NUC from USB minimal iso image I get following error at boot trying to enter installer:

Invalid image
Failed to read header: Unsupported
Failed to load header: Unsupported
start_image() returned Unsupported

Secure Boot is disabled (tried enabled also).
UEFI mode enabled.
Anybody has came across similar issue?

Thanks in advance for any suggestions.

UPDATE: Solved. Maybe somebody will find it helpful.

I can proceed with installation on my NUC.
Surprisingly I had to switch to Legacy Boot mode instead of UEFI Boot mode and keeping Secure Boot disabled it allows installer to initiate.

i guess the issue is how you create your usb

What is a good method for USB creation?

If this helps, I used two apps to create install USB:
Rufus and Etcher, both in ISO mode (not DD), both produced same result.

My issue was related to boot mode in BIOS (was UEFI, but Legacy worked) which was kind of surprise as I had CentOS 8 installed previously with UEFI.

1 Like

use DD mode and make sure the target system is UEFI

1 Like

there rufus if you use windows and fedora media creator https://getfedora.org/fmw/FedoraMediaWriter-win32-latest.exe or https://getfedora.org/fmw/FedoraMediaWriter-osx-latest.dmg if you use win or mac

1 Like

You can also do it with gnome-disk-utility installed. Right click on the ISO, then in the popup menu you can choose Open With → Disk Image Writer.

This is how I do it from my Fedora 35 install anyway. I haven’t found Fedora Media Writer any newer than something that was released for Fedora 24 when I googled (although it seems it’s available to install with flatpak). I really liked the way it was possible in Linux Mint using the USB Image Writer.

1 Like