Interface missing while installing RL 8.4 on VMware Workstation Pro

Sir,

I tried installing RL 8.4 on VMware Workstation Pro.
Interface missing while installing RL 8.4 on VMware Workstation Pro
There is no option to add the interface while installation.

image

Thanks and Regards,
JP

There’s already option to do that. just click plus + button at the bottom of you current menu settiong then choose Network Adapter then click finish. See SS below.

You can also create Virtual netwrok interface with Virtual Network Editor in VMware Workstation Pro.

I have done the same,
but not luck

image

I have centos8 and 7 working fine on the same setup.
But rocky linux is not working.

All the screens shown are for VMware Workstation.

What is happening in Anaconda?

You need to activate the network interface manually if you are using the GUI installer. This is the same as with RHEL. For example see below side-by-side comparison of RHEL and Rocky Linux…

Tried with below two images.
Rocky-8.4-x86_64-dvd1.iso
Rocky-8.4-x86_64-minimal.iso

pasting the screen shots here

Iam not getting that option to add the interface

You do not add the interface inside Anaconda you need to create the required virtual network interface(s) to pass into the guest from the VMware Workstation UI on the host.

If you don’t do that the guest (ie. Anaconda in Rocky Linux installer) will not see any network devices to configure.

I don’t have access to a Windows or Linux host with VMware Workstation but I have verified in VMware Fusion (the macOS equivalent) that adding an autodetect network adapater to the guest configuration…

…causes the device to be detected inside the running VM and allows it to be configured…

Assuming your host configuration is correct and there is no firewall blocking outbound traffic you should be able to access hosts on the Internet, including the Rocky download servers and mirrors.

If you do not see an Ethernet device in the Network and Host Name panel in Anaconda you will not be able to complete a network install.

I can guess you’re using VMware Workstation Pro 16, It seems RockyLinux 8.4 does not have appropriate driver for NIC when you choose Hardware compatibility Workstation 16.x in VM creation.

In “New Virtual Machine Wizard” choose advanced option, in next step choose one of the hardware compatibility less than “Workstaion 16.x” and keep on setting new VM.

in this way you have no problem for NIC detection by installer

I wish it could help you

That’s is not the same. as my first SS above after I create VMware virtual network in Virtual Network Editor, so in VMware Workstation in setting i choose Custom network adapter, which vmnet0 created by Virtual Network Editor before. Rocky linux is working flawlessly in VMware Workstration in Fedora 34 Hos OS. I’m not using NAT. In those SS NAT is just example but actually I’m using custom network adapter before installed Rocky Linux in VMware Workstation with host os is Fedora 34.

If VMware (I’ve never used it, just libvirt/KVM) setup for both VM (centos8 and rocky) was identical, then it would have been interesting to see the lspci from both. (One can switch to text console during installer, although don’t known whether it has lspci …)

This is My Rocky Linux VM in WMware workstation with custom virtual network vmnet0