Installation of Rocky 8.4 on ESXi 6.5

I’m not sure if I’m doing anything wrong… but at the same time there’s little that can go wrong on my procedure.

I’ve installed a Centos 8 right this morning on ESXi 6.5 (standalone latest patch level - July 2021), no issue it just worked.

After that I downloaded Rocky (tried both both Minimal and DVD with same result). After the VM is created and the DVD image virtually connected, the POST just failes as no booting devices are found. I ahve never had to do this but I also tried to enter the BIOS and set the CDROM as first booting device, still no luck. I have also tried setting up the VM config in multiple ways like Centos7/RHEL7/Other Linux x64 but nothing seems to allow me to boot from the ISO image.

Is this a known issue? Or am I perhaps supposed to do things differently?


Answering myself… It finally booted off using the ISO image x86_64 instead than the aarch64

Hi, yes aarch64 will be for ARM processors.

This is what’s happening when you’re dyslexic and you just don’t see the difference between ARM and AMD

1 Like

Hi ! I have the same problem but in real !! On esxi 6.7 fresh install, It’s not ARM iso but X64 and when I try to boot, no boot on the rocky installation:

I try SE guest in centos8 mode or Redhat 8 but same !

thank a lot :wink:

In your case, you will need to disable secure boot if it’s enabled.

Thank you very much it’s the good way ! I can continue my test with esxi !

Running into a similar problem here but I think it might just be an unsupported platform at the moment and I’ll need to wait. Trying to load Rocky on the VMWare Fusion Player preview for M1 Macs. Tried both x86_64 and aarch64 isos with the same result as what is described in this thread. Anyone have any luck trying this out on MacOS w/ an M1 yet?

I installed RL 8.4 GA since the first release date. I use VMware workstation pro 16. There is no problem and smooth installing. Yes it’s right disable secure boot and if you confuse just choose in linux version as Centos 8 (64bit).