Kernel Modules for installing VMware workstation 17

Dear Rocky friends

I want to communicate You that I face issues for the lack of modules from the Kernel version that stop the smooth prompt and running of workstation 17.5.

I guess that that RockyLinux 9.4 comes with a kernel version that was not very up to date with latest Kernel , am I wrong ?

I already run the “modorobe” command but I couldn’t load such modules ”vmmon” and “vmnet”.

I am bit confused what to do since this case where there is a lack of modules ,
anyone has suggestions to troubleshoot this issue?

Hi Andre,

the situation is, that VMware provides their own kernel modules with VMware Workstation and VMware Workstation Player.
These have been migrated to use DKMS in the last year if I remember correctly, which made the whole experience somewhat seamless, but as the 9.4 release brought a new kernel version with kABI changes, the DKMS build fails.

Documented that in the issue here as well: 0006570: VMware Workstation Player inoperable after kernel update - Rocky Linux BugTracker

So there are 3 options:

Hope this helps!

1 Like

Thank you for the help and clarity.
Hopefully there will be soon the possibility to install VMware workstation on rocky. :+1: