I can't install rocky on parallels

i can’t install rocky on parallels. where could i be doing wrong? i need it for my devops work. can someone help with this? i have tried almost all of them from the downloads section.

We need more information. What version of Rocky? Why isn’t it working? What errors are you seeing? Parallels is proprietary platform for VM’s, so you may wish to ask them if they support the version of EL Linux you are attempting to install - be it RHEL8/Rocky8 or RHEL9/Rocky9. Maybe Parallels doesn’t support the version you are attempting to install.

RHEL9/Rocky9 requires minimum hardware requiresments that support CPU with x88_64_v2 - if you don’t have this, it won’t work.