HP z620 install doesn't show the local disk

I tried to install 8.5 on a HP z620 but the installer doesn’t show the local disk(s). I also tried RHEL8 but it exhibited the same behavior. Ubuntu installed without issue. I’ve read other posts that talk about missing drivers but how can I figure out if this is the issue and if so how would I go about resolving it. I’d like to use Rocky but right now I can’t.

What I would do is while you’re in the installer, CTRL+ALT+F2 (?) or another that will lead you to a bash shell. Run lspci and it should spit out what you have hardware wise and that can potentially help us identify what driver you may need.

More specifically, lspci -nn. The nn options make it show device ID, for example [14e4:1639]. The ID tells exact model of a device and drivers list IDs that they support…

There appear to be 2 SATA devices.
Here’s the disk controller that I think the disk is connected to:
00:f2.2 SATA Controller [0106] Intel Corporation C600/X79 series chipset 6-Port SATA AHCI Controller [8086:1d02] (rev 05)

Not sure about this device:
02:00.0 Serial Attached SCSI Controller [0107] Intel Corporation C602 chipset 4-Port SATA Storage Control Unit [8086:1d6b]

$ modprobe -c | grep -i 8086.*1d6b
$ modprobe -c | grep -i 8086.*1d02
alias pci:v00008086d00001D02sv*sd*bc*sc*i* ahci
$

The [8086:1d02] should work with ahci driver module.

The 1d6b is not found even from ELrepo list: ELRepo | DeviceIDs
In EL7 it was supported by isci.

I see that module so what else could be stopping the installer from recognizing the disk?

Are there any logs at this point in the install that I can look at?

Sorry, that DeviceID page needs updating. [8086:1d6b] is supported by the kmod-isci package for el8.

@txtoth Please try installing

https://elrepo.org/linux/elrepo/el8/x86_64/RPMS/kmod-isci-1.2.0-8.el8_4.elrepo.x86_64.rpm

It’s tagged as .el8_4 but should be upward compatible with el8_5.

[EDIT] The Elrepo DeviceIDs page updated with kmod-isci.

If installer does not see the disks, then one would have to use the dd (driver disk) image?
The inst.dd=<location> kernel command-line option for the installer.

Quite right. The DUD image is:

https://elrepo.org/linux/dud/el8/x86_64/dd-isci-1.2.0-8.el8_4.elrepo.iso

Thanks for the information which I may eventually use. In the meantime I’ve ordered a disk controller card (only $35) to see if it will allow the disks to be seen without having to jump through this hoop.

Using the new disk controller card worked. Installer now sees disks and completed without issue.