Cant Launch Google-Chrome-on-RL9

Good evening.

I have an issue with launching google-chrome web browser in Rocky Linux 9. This happened after removing old kernel modules.

When i launch the web browser, i get this error :-

MESA-INTEL: warning: Ivy Bridge Vulkan support is incomplete
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[12095:12095:0910/233115.634864:ERROR:gpu_memory_buffer_support_x11.cc(44)] dri3 extension not supported.

The repolist looks like this.

dnf repolist
repo id repo name
appstream Rocky Linux 9 - AppStream
baseos Rocky Linux 9 - BaseOS
crb Rocky Linux 9 - CRB
epel Extra Packages for Enterprise Linux 9 - x86_64
extras Rocky Linux 9 - Extras
google-chrome google-chrome
mongodb-org-5.0 MongoDB Repository
pritunl Pritunl Stable Repository
rpmfusion-free-updates RPM Fusion for EL 9 - Free - Updates

My kernel-release
uname -r
5.14.0-70.22.1.el9_0.x86_64

Important to point out, Mozilla Firefox is working okay.

Am not sure i have the fix to this. Either, i didn’t find something substantial on stack overflow. Please assist.

Which kernel modules and why did you remove them?

I removed the old kernel versions as they had piled up. Sorry , used modules instead of old kernel releases.

You don’t need to remove old kernel versions, Rocky will do that for you.
It looks like something went wrong with the graphics driver, could be that your driver was tied to a specific kernel version.
Did you try uninstalling, and then re-installing Chrome?

From your more recent post, it sounds like this is a bigger problem, not really to do with Chrome.

@gerry666uk I am so so scared . The thought of losing data on this production server is sickening.

What do you suggest I do sir ?

@gerry666uk that was the first thing I tried to do. I uninstalled chrome , and reinstalled it but the same problem persisted.

Let me explain what I did.

  1. I listed the kernel versions on the system, and found out that I had several.
  2. I removed the old kernel versions to remain with the latest one .
  3. Trying to launch google Chrome, it couldn’t launch but Mozilla was okay.
  4. I have now lost my System ( connect to the topic I raised on Gdm failing to start)

Using Ctrl+Alt+F2 I am able to get to the console, and login as myself . Can I recover data from the console? Am not a pro in RL yet. Pls tell me what you think.

Thank you

Let’s try to deal with this part first.

If it’s a production server, the o/s will be on it’s own disk or on it’s own partition, and a re-install from scratch has already been tested, plus all the data is backed up and in a safe place using open standards formats, so it can be restored to “anywhere” it’s needed. If any of that isn’t true, it’s probably time for a re-think.

At this point, it’s unlikely you’ve lost any data. The issue is that you can’t use the machine from the GUI.

Here are some ideas:

  1. Try to make it work again, by back-tracking over what caused the GUI to stop working. This would be great, but might not be possible.
  2. Work out if you can access the broken computer from a working computer over the network, e.g. can you ssh into it from a different machine? If you can, it’s fairly easy to copy from one to the other.
  3. Can you use a USB stick with the broken machine. I’m guessing you can’t copy and paste text from it, because you’re in a huge text based console? If you can get a USB stick working, you’d be able to run commands and pipe the results into text files which you could then post on here.
  4. If you’ve got a lot of unallocated disk space on the broken machine, you may be able to do a new Rocky install, with new volumes, without overwriting any of the volumes where your data is stored. Even with limited disk space you may be able to “re-format” the volumes that don’t hold your data, but this is getting into high risk.

If you can answer 1-4, it should help others on the forum to give some guidance on the next steps.

1 Like

Hi, on the topic regarding Chrome not starting:

Once you have solved the much bigger issues around GDM / login to the GUI, you could probably try to start Chrome in safe mode (meaning: disabling all addons/extensions/plugins, whatever it’s called and if that is possible) to see if it makes a difference.
But I go along with @gerry666uk in suspecting the graphics driver to have an issue with the newer kernel, not specifically with your attempts to remove old kernel files.

HTH, Thomas

1 Like

Before installing a new kernel, you should uninstall privative graphic drivers or modules from kernel and then install a new kernel without uninstalling old kernel. I suggest you to install again the default kernel. Installed modules are linked to default or current kernel. If you remove, something are missing, that’s the error…

1 Like

Thank you all for your Help.

Let me implement your suggestions and see how it goes.

Sorry was on holiday .

And true to @gerry666uk , the graphics driver was the issue. Thank you sir and much appreciated.

Yes my Question was answered.