Rocky Linux Kernel update broke nvidia driver

Hi, we were just beginning to migrate to Rocky Linux 9.3 and I noticed that the imaged servers were broken and then through troubleshooting saw that that OS wasn’t communicating with the Nvidia Card.

Kernel: kernel-5.14.0-362.18.1.el9_3.0.1.x86_64.rpm

rolling back to kernel-5.14.0-362.18.1.el9_3.x86_64.rpm fixes the issue. I’ve noticed that the working kernel is already removed, but fortunately our foreman mirror is retaining out of date packages. Is there somewhere that I can report this issue?

You can report it to nvidia. However, I wish you luck in this, as they have ignored our suggestions to fixing their packages. They are notorious for hard locking on specific kernel versions and not taking advantage of weak modules.

Consider the following options:

  • Use rpmfusion for your nvidia driver
  • If you wish to use nvidia’s packages, use dkms instead of the precompiled driver
2 Likes

Thanks buddy. Seems very irresponsible that they already nuked the older package. That was a real kick in the stones. Like I said, thank God we have it retained on our mirror or we’d be in deep doodoo.

Hello. I suffered same thing when I updated to 9.3. And I did use the rpmfusion driver. I fixed it uninstalling nvidia driver (and cuda toolkit and nvidia container toolkit), and reinstalling them. It works now. Regards.