NVIDIA modules problem when updating

Hello. I installed Rocky some time ago in my home server. Xeon v2 + Nvidia GTX 1070.

/etc/os-release

NAME="Rocky Linux"
VERSION="9.3 (Blue Onyx)"
ID="rocky"
ID_LIKE="rhel centos fedora"
VERSION_ID="9.3"
PLATFORM_ID="platform:el9"
PRETTY_NAME="Rocky Linux 9.3 (Blue Onyx)"
ANSI_COLOR="0;32"
LOGO="fedora-logo-icon"
CPE_NAME="cpe:/o:rocky:rocky:9::baseos"
HOME_URL="https://rockylinux.org/"
BUG_REPORT_URL="https://bugs.rockylinux.org/"
SUPPORT_END="2032-05-31"
ROCKY_SUPPORT_PRODUCT="Rocky-Linux-9"
ROCKY_SUPPORT_PRODUCT_VERSION="9.3"
REDHAT_SUPPORT_PRODUCT="Rocky Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="9.3"

My repo list

appstream                            Rocky Linux 9 - AppStream
baseos                               Rocky Linux 9 - BaseOS
crb                                  Rocky Linux 9 - CRB
epel                                 Extra Packages for Enterprise Linux 9 - x86_64
epel-cisco-openh264                  Extra Packages for Enterprise Linux 9 openh264 (From Cisco) - x86_64
extras                               Rocky Linux 9 - Extras
libnvidia-container                  libnvidia-container
rpmfusion-free-updates               RPM Fusion for EL 9 - Free - Updates
rpmfusion-nonfree-updates            RPM Fusion for EL 9 - Nonfree - Updates
xpra                                 Xpra 9 - x86_64

my nvidia installed packages

dnf list --installed | grep nvidia
akmod-nvidia.x86_64                          3:545.29.06-1.el9                   @rpmfusion-nonfree-updates
kmod-nvidia-5.14.0-284.el9_2.x86_64          3:525.116.04-1.el9                  @@commandline             
kmod-nvidia-5.14.0-362.el9_3.x86_64          3:525.116.04-1.el9                  @@commandline             
libnvidia-container-tools.x86_64             1.13.5-1                            @libnvidia-container      
libnvidia-container1.x86_64                  1.13.5-1                            @libnvidia-container      
nvidia-container-toolkit.x86_64              1.13.5-1                            @libnvidia-container      
nvidia-container-toolkit-base.x86_64         1.13.5-1                            @libnvidia-container      
nvidia-modprobe.x86_64                       3:545.29.06-1.el9                   @rpmfusion-nonfree-updates
nvidia-persistenced.x86_64                   3:525.116.04-1.el9                  @rpmfusion-nonfree-updates
nvidia-settings.x86_64                       3:545.29.06-1.el9                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                   3:545.29.06-1.el9                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64              3:525.116.04-1.el9                  @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64         3:525.116.04-1.el9                  @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64           3:545.29.06-1.el9                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64              3:545.29.06-1.el9                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64             3:545.29.06-1.el9                   @rpmfusion-nonfree-updates
xpra-codecs-nvidia.x86_64                    5.0.3-10.r1.el9                     @xpra

Now I’m getting these errors when I do dnf update

Error: Transaction test error:
  file /lib/modules/5.14.0-362.8.1.el9_3.x86_64/extra/nvidia/nvidia-drm.ko.xz from install of kmod-nvidia-5.14.0-362.el9_3-3:545.29.06-1.el9.x86_64 conflicts with file from package kmod-nvidia-5.14.0-362.el9_3-3:525.116.04-1.el9.x86_64
  file /lib/modules/5.14.0-362.8.1.el9_3.x86_64/extra/nvidia/nvidia-modeset.ko.xz from install of kmod-nvidia-5.14.0-362.el9_3-3:545.29.06-1.el9.x86_64 conflicts with file from package kmod-nvidia-5.14.0-362.el9_3-3:525.116.04-1.el9.x86_64
  file /lib/modules/5.14.0-362.8.1.el9_3.x86_64/extra/nvidia/nvidia-peermem.ko.xz from install of kmod-nvidia-5.14.0-362.el9_3-3:545.29.06-1.el9.x86_64 conflicts with file from package kmod-nvidia-5.14.0-362.el9_3-3:525.116.04-1.el9.x86_64
  file /lib/modules/5.14.0-362.8.1.el9_3.x86_64/extra/nvidia/nvidia-uvm.ko.xz from install of kmod-nvidia-5.14.0-362.el9_3-3:545.29.06-1.el9.x86_64 conflicts with file from package kmod-nvidia-5.14.0-362.el9_3-3:525.116.04-1.el9.x86_64
  file /lib/modules/5.14.0-362.8.1.el9_3.x86_64/extra/nvidia/nvidia.ko.xz from install of kmod-nvidia-5.14.0-362.el9_3-3:545.29.06-1.el9.x86_64 conflicts with file from package kmod-nvidia-5.14.0-362.el9_3-3:525.116.04-1.el9.x86_64

Best way to surpase/fix this?

Fixed. Stopped Lightdm service and did snap disable lxd, just in case.

Then uninstalled nvidia-container-toolkit and akmod-nvidia.

After a while, reboot,

Reinstall the things, reboot, and now all tthis is working.

EDIT: strange, can’t find nvidia-smi ?!? But the drivers and the container toolkit are working ok.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.