Rocky Linux 9.4 and Nvidia

OK I have been away for a bit. My buddy and I have migrated to openSUSE 15.5, with Rocky Linux 9.3 as a backup which gave us troubles. I get to be the guinea pig, and with the release of Rocky Linux 9.4 I had first crack at it. WOW!!! I LOVE it!!! There however a tiny fly I had in 9.3 and wonder if it is still in 9.4: Nvidia drivers. I never got that to run and trying to over come it took the whole system down. I gave up and it screwed up every thing. I have 9.4 up and rocking… minus either Amarok or Clementine, but did get VLC installed. I did get Clementine installed via SNAPD and SNAP but that lead to a different set of problems so deleted it ( if you do install it start up GNOME SYSTEM MONITOR then go over to FILE SYSTEMS and you will see several file systems that are 100% filled., to get rid of them to to /var/log and look for either SNAP or SNAPD and look inside then start deleting the contents). I also had troubles installing SKYPE, but did find a way to install that. I was able to install CINNAMON installed., but have not been able to install MATE. As it stands now I have KDE, GNOME, Xfce, and CINNAMON DE installed. I have 4 users installed, 10 Virtual Desktops installed, each with its own Wallpaper and each with its own set of Widgets. I can bounce around the computer with EASE, much like I can do on “leopard”. The ONE thing I have not tried is to install NVIDIA drivers (for my GeForce GTX 1050 Ti Graphics Card). Has anyone got NVIDIA drivers installed on RL 9.4 or are you still stuck in nouveau? If you did get NVIDIA drivers installed – and NVIDIA actually WORKS!! – could you PLEASE tell me how you got it installed. The other thing that I would love to get installed is either AMAROK or CINNAMON. AMAROK is probably a dead cause, but CINNAMON … I would hope that could be installed without going through SNAPD or SNAP – thrust me it starts filling up your /var/log.

Anywho I LOVE Rocky Linux 9.4. I just want to know if I can get the NVIDIA drivers installed without blowing up the system.

Thanks

I have it installed by going to nvidia, getting an account, and installing the nvidia drivers and cuda.

Their instructions worked beautifullly. I have been running this now for I think years (through 9.3, and earlier, if memory serves).

I just realized I don’t have this on my replacement box, and so I will be doing this on that machine shortly, when I get a chance. I thought I had another post here giving this same advice, and my use of this predates that. I run KDE pretty much exclusively. However, I don’t see that post, so I’ll try to do one when I do this process on the new machine, and let you know if I see any issues in it.

Hope this is helpful.

Cheers
Mike

And just finished this out, it worked great.

Also, I used the “open-dkms” version of the nvidia driver, not the legacy version. I suspect on my main workhorse, it was the “legacy” version. (which again, has been working fine).

It’s basically getting into the cuda software development repo, but the instructions for Rocky are pretty straightforward (and Rocky is actually called out as one of the distros!) I did the net install, so it’s install the repo, then cuda, then the nvidia drivers.

If this doesn’t look familiar when you try to do it, let me know and I’ll try to help. Maybe your card is something special, but I believe there is a “supported hardware” link there.

Mike

At this moment there are at least three RPM repos that have the NVidia proprietary driver for el9: RPMFusion, NVidia, and ELRepo. Only RPMFusion has built some legacy series drivers for older cards. Only NVidia has all the CUDA packages (should one need them).

Thanks Mike. Yes I too am running KDE, only ver. 5.27.11… exclusively, though I also have Xfce, GNOME, and Cinnamon also loaded as backup DE and also places where I can check KDE against just in case something goes out in the weeds. It was when I tried to install the nvidia divers in 9.3 that toasted me – my buddy had no such problems, so this time I’m going to allow him to do the install… THOUGH THIS TIME I HAVE BACKED UP THE ENTIRE DRIVE AS I GO ALONG!!! Besides now having installed ZSH, with my custom and very colorful PROMPT, with a few new additions and twists (an ongoing work that has never been finished); I got VLC installed along wirh Clementine – whatever you do DO NOT USE SNAP/SNAPD, you CAN HOWEVER INSTALL IT VIA FLATPAK – I just finished installing GOOGLE EARTH PRO 7.3.6, and it works!! I also have SCRIBUS 1.6.1, installed along with the SUBLIME Text Editor ( ver. 4169 ) installed in the event my every trusty Midnight Commander is not up for the job ( have been using that or its parent Norton Commander going back to my days in M$DOS 3.2 – yeah, just showed my age!) . It is always the FIRST program I load usually right after I do a yum/dnf update.

The ONE program that has defeated me twice now :rage: is installing VMware Player 17.5.1 It gets all the way to the end, has told me that the install was a SUCCESS, but then tells me that something went wrong and it is missing some package or something and thus the install FAILED!! My buddy claims he ran into this problem too, and then he waved his magic wand while speaking words of enchantment and he got it to work!! So this too may be where he will have to step in. If worse comes to worse I may have to drop over to leopard that is still running CentOS 7.9 (!!!) but still has a functioning VMware Player. Compared to ocelot with its 128 GB of RAM, and 12 core Ryzen CPU, it is painfully S-L-O-W!!

I still have a few more packages that need to be installed, but they are programs I tend not to use much, but are nice to have installed “just in case” someone drops over and needs to “barrow” my machine – Just a quick matter of logging out and logging them in.

With the exception of installing the NVIDIA DRIVERS and getting the VMware Player installed, 9.4 is rather CLEAN, and no major GOTCHAS . Indeed as the sun sank below the yardarm, I decided to pop in my copy of Phantom of the Opera, and it Sang For Me producing the Music Of The Night!!!

1 Like

Is this possibly the signing of the EFI bits? (on the vmware?)

My kde is the 5.27.11 now, so that’s the same. I have been using virtual box, but now that I tried it again, I’ll have to deal with the EFI signing fun (which I actually like the idea of). I don’t run vmware on these machines.

I try to stay away from Snap, and there’s nothing there I really need, I think. I did try it, and pulled it all out as the benefit/work ratio didn’t justify it.

I will be intrigued to see how the nvidia works for you.

Cheers
Mike

I have installed recent (version 550) Nvidia drivers from the Nvidia repos on Rocky 9.4 and it works as expected. I used nvidia-driver:latest-dkms.

For the older driver v470, the version provided by RPMFusion is NOT compatible with Rocky 9.4 and will fail to compile. No other repo (to my knowledge) provides older Nvidia drivers.

If you enable ELRepo’s testing repository (“elrepo-testing”), we have the NVIDIA 470xx driver (kmod-nvidia-470xx) compatible with EL 9.4.

2 Likes