Rocky Linux 9.4 Available Now

Rocky Linux 9.4 has been released. See our release announcement for more details.

Thank you for supporting Rocky Linux!


Sincerely,
Release Engineering @ The Rocky Linux Project
https://rockylinux.org

8 Likes

But it does not working at my computer and it lost all my nivida drivers . Rocky updated by it self, but then I got the message that I missing just installed nivida drivers and it is even not opens, I have just a black screen… alas.

Hi All,
I’m wondering when Rocky will upgrade to glibc_2.39. given that there is a serious vulnerability in previous versions.
Cheers,
David

Security patches are backported into our version, which removes the need to upgrade glibc. I should note that even if we wanted to upgrade glibc, we would have to rebuild the entire release.

If there are vulnerabilities that are not fixed as indicated by the change log, please notify us at bugs.rockylinux.org.

If you mean CVE 2024-2961 have a look at
https://access.redhat.com/security/cve/CVE-2024-2961

Even RedHat does not have updated packages for RHEL 9 yet?
But look at that

hey team,

Really appreciate all that is done, but can I ask why as soon as a new release is done that the old files get moved to the vault. ie https://download.rockylinux.org/pub/rocky/9.3/README.txt
it kills any kickstart configs that are out there that call like url --url=“https://dl.rockylinux.org/pub/rocky/$releasever/BaseOS/$basearch/os/

thanks

This is detailed in our version policy. Old versions are always moved to the vault immediately.

Maybe worth trying $releasever_major instead of $releasever
https://dnf.readthedocs.io/en/latest/conf_ref.html#repo-variables-label

Doesn’t $releasever hold just the major?
(That is why repos have the 9 → 9.x symlink – for baseurl access. The mirrorlist server now hands out explicit “9.4” urls, when you ask for “9”.)

Since the URL in kickstart now points to 9.4, the issue is probably not the URL per se,
but that one still boots with 9.3’s vmlinuz and initrd, which do not expect new content?
In other words the solution would be to update vmlinuz and initrd.

1 Like

Yes it does, and I’m not surprised. So it’s probably not the move to vault which is causing trouble for @djg

A note on the $releasever_major (and $releasever_minor) variable. It’s available in fedora, but not yet in RHEL and clones.

1 Like

so as far as I can see its looking for the 9.3 files, what I have is a kernel and initrd then go looking for stage2, then its in the kickstart that its getting the problems, its as mentioned its not symlinked and its just now an empty folder with a readme. ive updated the kickstarts to look for vault, but I think ill go hunt for a better solution, im having to do a fresh install as we use LUKS + clevis and tang for disk encryption and dynamically generate the kickstart of our server + disk keys per client on an install.
thanks

The solution here is to update your vmlinuz and initrd to 9.4. Since, at that point, those two files will be referencing 9.4 and the kernel and modules will match that version.

In my experience, upon a new release of a new version of a distribution such as this, the necessary boot files were updated immediately. This combats not only the problem you’re referring to, but potentially other problems you may run into installing a new version using older versions of the initramfs and kernel.

I tried to open an issue at https://bugs.rockylinux.org/ but the validation email isn’t coming through so I was unable to register.

If I create an EC2 instance from the Rocky 9.3 AWS AMI (ami-067daee80a6d36ac0, Rocky-9-EC2-Base-9.3-20231113.0.x86_64), I can update to 9.4 with all the latest packages (including kernel-5.14.0-427.16.1.el9_4.x86_64) and things work fine.

If I create an EC2 instance from the Rocky 9.4 AWS AMI (ami-0508b16bdd1180544, Rocky-9-EC2-Base-9.4-20240509.0.x86_64), it initially boots normally (with kernel-5.14.0-427.13.1.el9_4.x86_64), but if I update all packages then subsequent boots hang with kernel-5.14.0-427.16.1.el9_4

I’ve tried with instance types t3.small and m6a.large and have the same issue on both.

[  206.238262] dracut-initqueue[425]: Warning: Could not boot.
         Starting Dracut Emergency Shell...
Warning: /dev/mapper/loop0p4 does not exist

Generating "/run/initramfs/rdsosreport.txt"


Entering emergency mode. Exit the shell to continue.
Type "journalctl" to view system logs.
You might want to save "/run/initramfs/rdsosreport.txt" to a USB stick or /boot
after mounting them and attach it to a bug report.

I am experiencing the same , opened topic https://forums.rockylinux.org/t/rocky-9-4-aws-ami-not-booting-after-kernel-update

Just installed Rocky 9.4 on Virtualbox 7.0 running KDE Plasma. Also installed xrdp, works using a bridged network interface. Will continue to test. No problems with epel-release.

DockerHub tags for 9.4 are not live yet? Last update for the current 9 tag is 6 months ago, despite the downloads page links to it (which actually is 9.3)

Following up in the main thread – the issue with the EC2 images will be resolved with images I upload today.

Thanks for your patience!

Heya - I halted the deployment to the ‘Official’ images because of some regressions to the images w.r.t. package set; I have new images that I will be publishing today.

1 Like

I am getting an error when trying to create a Rocky 9 vm in Azure, opened topic Error trying to create Rocky 9 vm in Azure