9.3 install on HP EliteDesk fails

Hi all,
Trying to install 9.3 on an Hp EliteDesk. The 9.3 installers (minimal and DVD both) get as far as
“`Reached target Path Units”
and that’s it.

I’d like to try 9.2, or really any of the previous 9 releases to see if this is something the older versions might bypass.

Alternatively, if there’s a way to get more info about what’s going wrong with the 9.3 installer that would be be even better.

Thanks!
Jeff Ross

Is it a clean build where you are not taking data risks?

If so you might try doing the install again with the BIOS set to not use Trusted Platform Module (TPM).

I’ve had an issue here with the update that I can’t resolve so I’ve been reading many help files.

I thought that TPM was required for virtualization.

Anyway, if you are on a clean build then trying this would be good. It didn’t solve a the problem here and is likely why I now have a new error to resolve. Don’t do it if you are upgrading with knowing what problems it might cause.

I’d start there if you can.

Yani

Where in the install process are you stopping, booting the installer or after making install selections and starting the install?
Did you disable fast boot in the firmware? Did you use “dd” to create the install image or some graphical tool?

After booting and choosing to install RockyLinux
9. 3. and before I can do any selections. There are 2 or 3 separate short sections of text that flash by, the last one and the one I quoted is where the system freezes. Sometimes the USB stick continues to flash as if it’s reading but it never stops and it doesn’t stay flashing on all attempts.

In the bios I do not see anything about fast boot. Other than setting the boot order I haven’t made any changes to the bios settings.

I used dd to write the iso file to usb.
Thanks for the reply!

Jeff

Clean brand new install. I’ll try that!
Jeff

Trusted Platform Module was not enabled. Still won’t get past the “Path Units” line.

Jeff

Have you tested / run the install media on another machine to see if it gets further? I’ve had some crappy memory stixs lately.
Is the HP running windows now?

Something to do with making aliases for files I think. Doesn’t sound like an install breaking issue from what I read.

Is it installed enough to get the OS started?

The HP came with windows but I installed OpenBSD on it immediately after I purchased it as a refurb. I never actually booted up windows but it ran OpenBSD just fine.

I booted the same installer “DVD” USB I’ve been trying on my recently converted to Rocky 9.3 2011 Early MacBook Pro. I then used a SATA to USB3 adapter and installed 9.3 on the SSD drive from the HP. I think because it was running Mac hardware I was not able to install the boot loader so it won’t boot but it certainly appeared to successfully do the complete install.

I may go back to that process and install the bootloader from the Rescue kernel and see what happens then.

I have 2 other of these HP EliteDesks computers–both older that the one I’m working on now. One is still running windows for the very odd time I have to have windows. The other is the computer I’m writing this from. I started with 9.2 on it and installed with no issues, then upgraded to 9.3. Interestingly enough–it will not boot the 9.3 DVD installer either.

That’s why I originally asked if the 9.2 installers are still available. I would not mind starting with 9.2 and then upgrading to 9.3.

Jeff

No–I never even get to the installer part.

Jeff

In the vault, but if it works update to 9.3 ASAP
https://dl.rockylinux.org/vault/rocky/9.2/isos/

Thanks! Digging around in my desk I found the 9.2 installer I used here and it doesn’t work either.

However, I set up my computer differently so I can see the activity light and it sure looks like that after I see the “No Signal - HDMI2” on my monitor something is still working. I see the activity light flashing at irregular intervals so maybe the install has lost the video and is waiting for me to respond.

The text install version does the same thing though.

I know there are multiple “virtual” consoles available during install–how do I switch to one of those? If that brings back even text maybe I can see what’s really going on.

I tried the Alma minimal install with exactly the same results and I’m going to try the latest Fedora net installer next.

Jeff

Fedora 39 Network Installer works in the Simple Graphics mode. It’s a little weird here because the “Continue” and so on buttons are off the bottom of the screen.

However, when it finished and told me to reboot I removed the install USB was was rewarded with a text login screen and then a successful login as the user I’d set up during the install.

Maybe I’m not the only one that’s had this problem. If so, I hope there’s enough information in the thread to help figure out what happens to the video.

Jeff

If you have done the install and can see the system starting to boot…

Press escape to watch the boot process.

Then when it has finished getting as fas as it going to get try Ctrl + Alt + F3

If you get a prompt that you can log on then

dnf upgrade --allowerasing

Instead of chasing a specific error, like I was doing, if you can, let the system sort it out.

If you don’t have another computer with net access that you can cable to then go visit a friend that does.

Hello @jross_mt

sorry if i suggest any option that you already tried

  1. did you check it the iso sha256 after you downloaded it checksum files
  2. how did you created your usb drive (i saw you said you had macbook) there fedora media writter

not sure if creating usb drive from gpt uefi (in mac case) for device like your hp (which could be old and use MBR with bios) could lead to issue or not

rufus give you option to handle those options but rufus work only on windows

hope any of that help and have a nice day :slight_smile:

Finally, success installing 9.3!

This HP EliteDesk has 2 displayports and a VGA connector. I dug out an old Samsung VGA monitor and the install went off without a hitch using the same USB drive and the DVD iso I’d been trying. After install one of the display port adapters

Thanks for the keyboard tips!

Jeff

1 Like

I did do the checksum check.

I created the USB disk on another HP EliteDesk running Rocky 9.3 and using dd.

Thanks for the suggestions! As I just posted, in my case hooking up a VGA monitor fixed the missing video and then I was able to finish the install.

Jeff

1 Like

@jross_mt you welcome and congratulations for figuring it out