HP Prodesk Tower 600G1 won't boot Minimal/boot cds

I bought this refurbed HP with the intention of wiping Win10 and replacing it with Rocky Linux. It will boot windows. But, when I change to boot drive to cd/dvd drive and insert a Rocky Linux 9.2 install CD, it gives an error message. I have used the linux boot cds to install Rocky Linux on a Toshiba laptop.

Any idea what is causing the problem? The cd/dvd drive recognizes and runs a Win10 repair cd. But not either of my Rocky Linux cds. There’s no option for chosing a USB stick.

Your processor is likely too old to be supported by Rocky Linux 9. You can verify this by running a Rocky Linux 8 installer. If it comes up, attempt to go to a terminal (e.g. ctrl+alt+f1) and run: /lib64/ld-linux-x86-64.so.2 --help

Subdirectories of glibc-hwcaps directories, in priority order:
  x86-64-v2 (supported, searched)

You will need at least x86-64-v2 for Rocky Linux 9 to run.

The processor is an Intel i5. I can’t boot linux off any removable media. Neither the BOOT nor the MINIMAL.

As I said, you should verify what I suggested above by booting Rocky Linux 8. Are you only trying Rocky Linux 9? Have you tried Rocky Linux 8 as suggested to verify the supported glibc hwcaps?

Intel has released 13 generations of “i5” CPUs, first around 2009.
First Intel CPU’s to support x86-64-v2 were also about 2009, but that does not mean that all do.
HP site says about “600 G1”: 4th gen CPU. Likely to support, but better to verify.

What does the message say?

Why not?

Error message: Invalid disk image. This was from trying to boot from either ‘boot’ iso or from ‘minimal’ iso.

There was no option in the boot devices for booting from USB memory stick. Yes, for USB hard drive (that didn’t work for a memory stick), and for ATAPI and USB cd/dvd druves. Those didn’t work either. None of the option in the boot lust would allow booting from a memory stick.

The ATAPI cd attempted to boot from the two iso dvds but failed with the error message above.

I discovered the cause. MS’s now adds a firmware option calls Secure Boot. If it is on, it prevents other operating systems from booting from any other media. Turning Secure Boot OFF fixed my problem.

I thought that Rocky already has signed kernel. Post Install Enabling Secure Boot - #2 by brian

The Secure Boot is a feature in UEFI mode boot. The firmware, UEFI (aka BIOS), has some certificates stored on the motherboard. The Secure Boot checks bootloader, kernel, and kernel modules that they are all signed by some of the certificate chains that the UEFI has. If signatures are not valid, then invalid components are not loaded.

Therefore, Secure Boot does not prevent “other” OS, just unknown OS, and Rocky ought to be known.
Then again, an ancient machine might not have valid certificates for any current OS.

It is possible to load certificates to the UEFI (with mokutil).

As old as that system is, the Secure Boot certificates in its BIOS might not be recent enough? The last BIOS for it–2.71–was released back in 2017…

In any case, glad you were able to find some kind of fix for it, though!

In my case, the server, a Dell 9xxx series, had a “legacy” BIOS option. I was able to install from the “minimal” ISO DVD. That worked.

Thank you. From its serial/model number, it was manufactured in 2019.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.