XRDP with XFCE not working - XRDP always starts up with GNOME

Hi,
I have installed ROcky Linux 8.10 with GNOME.
In addition XFCE is installed and can be started when being locally at the machine by the login screen - works well - XFCE comes up flawlessly.

For XRDP I tried to :

  • set “xfce4-session” in .xsession in my users home directory
  • set “startxfce4” in startwm.sh in my users home directory alternatively/in addition

… but alwys I end up with GNOME in a RDP session.

By setting “export GNOME_SHELL_SESSION_MODE=classic” I can at least switch to classic GNOME - anyway also here .xsession and startwm.sh are ignored - and xfce4 is not chosen.

Has somebody managed to run over RDP successfully with the standar GNOME installation under Rocky Linux 8 (or 9) another (lightweight) windows manager like xfce or mate ?

If yes - please let me know how … :wink:

My ~/.xsession has mode 700 and the following contents:

/usr/bin/dbus-launch --exit-with-session xfce4-session

I have no user startwm.sh file and no relevant changes to the system startwm.sh.

Excellent - that worked out - thank you so much - you made my day :pray: