Where is BackupPC

I am not able to find a BackupPC package to Rocky 9. I’ve installed epel, but nothing shows up.

ANy ideas where to look, or what repo I need to install BackupPC.


A good place to search is pkgs.org: https://pkgs.org/search/?q=backuppc

But as you probably already know, there isn’t an EL9 package for it. Whether a Fedora 35/36 package would work or not, you could always try. Some other posts on this forums when similar questions for packages have been asked, suggest using Mock and a src rpm for you to then build it yourself.

Otherwise, I guess we just have to wait until EPEL package it.

This is disappointing. I just installed 9.1 on separate partition of my RL8 server and everything was going well until attempting to install BackupPC.
Did the OP find a suitable source? The biggest issue when it is not distro-packaged is hunting down the Perl dependencies that are specific to BackupPC.
Anyway who do I pester to get this in EPEL?

BackupPC is supported through the RL8 repos so what if I just enable those for the install of this software and dependencies?

EPEL. They have their own channels for feature request/bug reports. See https://docs.fedoraproject.org/en-US/epel/epel-package-request/

Don’t. That will create a mess even if installation seems to succeed.

@iwalker did mention “Mock and a src rpm”.

For each binary package there should be a source package that the binary is built from.
If you have the backuppc*.src.rpm from closest similar distro (EPEL8 or Fedora?), then
you could try to build the binary package on Rocky platform. That way your binary package
would depend on Rocky 9’s libraries.

The mock is a tool that conveniently does the build.

It might be that build fails because el9 does not have what the build requires. One should not go into rabbit’s hole of building missing dependencies first. Let the EPEL maintainers work around that.

1 Like

Will most likely be best to put in a request with EPEL. I’ve just tried to build BackupPC using src rpm from Fedora 36, 37, and also from EPEL8 but seems to complain about a perl (BackupPC::XS) dependency. I’m not a huge user of mock, so haven’t really delved into how I might be able to resolve/fix that problem.

This is available on the github site so I guess has to be built also.
These are the only dependencies not provided in RL9 repos:
The FTP perl modules probably aren’t needed since I don’t use that method of flie transfer.

I’ve just downloaded the BackupPC-XS src rpm, so gonna see if building and installing this first will provide a bit more success or not.

Hmm, well that didn’t work. I tried building and installing BackupPC-XS which was fine, but then mock wouldn’t find it when I tried to build BackupPC. So I then tried to get Mock to build both at the same time thinking that would install it into the mock chroot. So to build BackupPC-XS first, and then start the second build. That also didn’t work.

As I said, not really a master of mock, so no idea how to get that to work to be honest. Maybe rpmbuild would be a way around it, but then apparently it’s not recommended to do it that way.

Well if you can’t I am not likely to be able to do it either as I haven’t built any srpm’s in many years.

Well I’ve managed to do it now from the Fedora 36 src rpms:

[ian@rocky9 ~]$ ls /var/lib/mock/rocky+epel-9-x86_64/result/

How I did it:

mock BackupPC-XS-0.62-7.fc36.src.rpm 
mock --install /var/lib/mock/rocky+epel-9-x86_64/result/BackupPC-XS-0.62-7.el9.x86_64.rpm 
mock --no-clean BackupPC-4.4.0-8.fc36.src.rpm 

first command built the BackupPC-XS dependency, of which I installed with the second command. Since Mock will cleanup each time it’s run, this was why it failed before. So for building BackupPC to use the installed dependency, required using --no-clean parameter.

The two rpms you can then copy from the results directory, and install them on the machines you need them.

1 Like

OK. Thanks, I’ll probably try this later today or next week. The remaining component is rsync-bpc which I can get the srpm also.
Your effort is appreciated.
So, now the question would be that if EPEL does provide BackupPC in the future will these packages be upgradeable. Not a big deal though. I know how to handle that situation.

1 Like

There might be a clue in the spec file of the main package, (BuildRequies), the child package has a list of --provides, and the parent package uses somthing like package kit (*.pc file) to find them, often from a *.devel package. I’m guessing on Fedora you can just install the *.rpm files (even in the wrong order) and it will trigger dependency resolution.

@gerry666uk already fixed it see two posts above yours. It’s to do with the way mock operates.

All built and installed.
I had to make the last two perl-Net modules from source also. Following your example worked for me. I’m not sure the mock --install step was necessary but mock --no-clean is for sure.
Well on to the next system configuration steps.

1 Like

I’ve gotten notice that the two dependencies for BackupPC have been built and are out for testing per EPEL
Branch and build perl-Net-FTP-AutoReconnect for EPEL 9

Branch and build perl-Net-FTP-RetrHandle for EPEL 9


1 Like

Yup, confirmed:

[root@rocky9 ~]# dnf --enablerepo=epel-testing search perl-Net-FTP*
Extra Packages for Enterprise Linux 9 - Testing 679 kB/s | 1.6 MB     00:02    
Last metadata expiration check: 0:00:01 ago on Sat 07 Jan 2023 02:36:34 PM CET.
========================= Name Matched: perl-Net-FTP* ==========================
perl-Net-FTP-AutoReconnect.noarch : FTP client class with automatic reconnect on
                                  : failure
perl-Net-FTP-AutoReconnect-tests.noarch : Tests for perl-Net-FTP-AutoReconnect
perl-Net-FTP-RetrHandle.noarch : File reading interface for reading files on a
                               : remote FTP server
perl-Net-FTP-RetrHandle-tests.noarch : Tests for perl-Net-FTP-RetrHandle

in epel-testing, so I guess at some point they’ll trickle down to main epel repository.

FYI…I reopened this Bugzilla to branch and build BackupPC for EPEL 9 2120957 – Please branch and build backuppc in EPEL9 a couple of weeks ago.

1 Like