Where all the packages gone in Rocky 9?

Hello All,

Just did the full rebuild on Rocky 9 and I’m hitting a lot of ‘No matches found.’ errors when I do dnf/yum search for packages like


$ dnf repolist
repo id                repo name
appstream              Rocky Linux 9 - AppStream
baseos                 Rocky Linux 9 - BaseOS
crb                    Rocky Linux 9 - CRB
epel                   Extra Packages for Enterprise Linux 9 - x86_64
extras                 Rocky Linux 9 - Extras
google-chrome          google-chrome
remi-modular           Remi's Modular repository for Enterprise Linux 9 - x86_64
remi-safe              Safe Remi's RPM repository for Enterprise Linux 9 - x86_64
rpmfusion-free-updates RPM Fusion for EL 9 - Free - Updates

Does anyone know how to have access to those basic packages, please? Are they going to be added to the repo or I will need to find something that actually hosts those packages?

Thank you!

transmission is an EPEL package. It was requested here.

gnome-tweaks is in appstream.

$ sudo dnf info gnome-tweaks
Last metadata expiration check: 1:14:11 ago on Sat 03 Sep 2022 10:44:23 PM MST.
Available Packages
Name         : gnome-tweaks
Version      : 40.0
Release      : 6.el9
Architecture : noarch
Size         : 316 k
Source       : gnome-tweaks-40.0-6.el9.src.rpm
Repository   : appstream
Summary      : Customize advanced GNOME 3 options
URL          : https://wiki.gnome.org/Apps/Tweaks
License      : GPLv3 and CC0
Description  : GNOME Tweaks allows adjusting advanced configuration settings in GNOME 3. This
             : includes things like the fonts used in user interface elements, alternative user
             : interface themes, changes in window management behavior, GNOME Shell appearance
             : and extension, etc.

As Enterprise Linux 9 is still fairly new, not a lot of packages have been built or branched to 9 as they would be in 7 or 8.

Thank you nazunalika. Forgot to add that I can find some of hte packages in the Gnome ‘Software’ application, but when I try to install them from there I get the “not supported” error.

What error do you get with commandline: sudo dnf install gnome-tweaks

Thank you jlehtone, it appears it was a Layer 8 issue.
Somehow when I tried to install it gave me the

No match for argument: gnome-tweaks

error, but after not sure what, I could finally install it in the CLI. The “Software” app still failed to do it with the “not supported” error.

I don’t understand any of that. What exacat command did you run and what exact output did you get?

Yes, I don’t think the software app is a good fit for the RHEL distro. As I understand it, you have to use ‘dnf’.

I can only show it with cherrytree as I was able to install tweaks after many tries/updates, etc. Still couldn’t figure what fixed the installation issue. But before I got exactly the same error for gnome-tweaks like below for cherrytree

$ sudo dnf install cherrytree
[sudo] password for chungli: 
Rocky Linux 9 - BaseOS                                                                                                  460  B/s | 3.6 kB     00:08    
Rocky Linux 9 - AppStream                                                                                               523  B/s | 3.6 kB     00:07    
Rocky Linux 9 - CRB                                                                                                     609  B/s | 3.6 kB     00:06    
Rocky Linux 9 - Extras                                                                                                  470  B/s | 2.9 kB     00:06    
No match for argument: cherrytree
Error: Unable to find a match: cherrytree

Thank you.

Layer 8 issue == Users fault :smile:

Google finds “cherrytree rpm” only for EPEL 7 and Fedora 35/36 … and perhaps as “snap”. So: neither EL8 nor EL9.