Rocky 9 and Telnet - missing

Strange enough telnet seems to be missing in Rock 9. I’ve tried both the x86_64 and aarch64 versions and the package seems to be missing from the AppStrem repository. I can find it however on RHEL9 and Alma 9 AppStreams…

Is this on purpose? I hate to see Rocky following the steps of macOS…

But ftp is there… so I guess it’s merely missing.

It is in the AppStream at

1 Like

Hum… I’ve just refreshed the x86_64 and it’s now available, but for the aarch64 is still no go:

[root@dhcp104 ~]# uname -a
Linux 5.14.0-70.13.1.el9.aarch64 #1 SMP Fri May 27 02:01:33 UTC 2022 aarch64 aarch64 aarch64 GNU/Linux
[root@dhcp104 ~]# dnf update --refresh
Rocky Linux 9 - BaseOS 2.1 kB/s | 3.6 kB 00:01
Rocky Linux 9 - AppStream 3.0 kB/s | 3.6 kB 00:01
Rocky Linux 9 - Extras 2.2 kB/s | 2.9 kB 00:01
Dependencies resolved.
Nothing to do.
[root@dhcp104 ~]# dnf list telnet
Last metadata expiration check: 0:00:05 ago on Sat 16 Jul 2022 01:24:13 PM -03.
Error: No matching Packages to list

Most likely the repos are still syncing.

Hum… I would exptect the “list” would be based on repo metadata. But let’s give it some time…

Not all repos are synced yet, they are overloaded right now as everyone tries to sync. I installed from DVD iso, so have telnet anyway so it is there. If the repo data hasn’t got it:

dnf clean all
dnf search telnet

maybe just cleaning and refreshing you might find a mirror that has almost finished. If not, should be sorted soon once all the mirrors have synced.


dnf -y install telnet

I just installed telnet. It seems that there is no problem

The package is located at: …/appstream/Packages/t/telnet-0.17-85.e19.x86_ 64.rpm

based on @joebeasley3 link it only show up for x86_x64 right now but not for other arch

so not sure if it repo sync thing or it missed for other arch

1 Like

Actually that could be a reason, good observation @JustSomeone but definitely exists for x86_64.

1 Like

Yeap, I also noticed that it’s available for x86_64 (see my second post) but still no aarch64. Also, it’s not on the DVD image:

[root@dhcp104 t]# uname -a
Linux 5.14.0-70.13.1.el9.aarch64 #1 SMP Fri May 27 02:01:33 UTC 2022 aarch64 aarch64 aarch64 GNU/Linux
[root@dhcp104 t]# pwd
[root@dhcp104 t]# ls telnet*
ls: cannot access ‘telnet*’: No such file or directory

Let’s hope it’s fixed soon, as it’s rather simple. For the time being one solution for those who need a telnet client is the grab the rpm from RHEL 9 or Alma and install from the command line. Once it’s fixed remove and reinstall.

This is a known issue, see:

I recommend in the meantime using the nc command instead from the nmap-ncat package in appstream.


the issue is fixed now @aviegas

Yeap! Been following the bug track. Still havent reached my mirror though, but eventually will.

1 Like

Still not available for me… :slightly_frowning_face: :slightly_frowning_face:


dnf clean all
dnf install telnet

that will clear your synced repodata, and sync it again before attempting to install the package.

[root@rocky9-aarch64 ian]# dnf install telnet
Last metadata expiration check: 0:03:42 ago on Wed 27 Jul 2022 09:26:19 PM CEST.
Dependencies resolved.
 Package                       Architecture                   Version                                Repository                        Size
 telnet                        aarch64                        1:0.17-85.el9                          appstream                         61 k

Transaction Summary
Install  1 Package

Total download size: 61 k
Installed size: 153 k
Is this ok [y/N]: y
Downloading Packages:
telnet-0.17-85.el9.aarch64.rpm                                                                               47 kB/s |  61 kB     00:01    
Total                                                                                                        23 kB/s |  61 kB     00:02     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                    1/1 
  Installing       : telnet-1:0.17-85.el9.aarch64                                                                                       1/1 
  Running scriptlet: telnet-1:0.17-85.el9.aarch64                                                                                       1/1 
  Verifying        : telnet-1:0.17-85.el9.aarch64                                                                                       1/1