Virtual Machine Manager vs. remote connection: weird errors

Hi,

I have KVM/libvirt + Virtual Machine manager installed on my main workstation running Rocky Linux 8, and everything works perfectly.

I have a similar KVM/libvirt + Virtual Machine Manager installation on a sandbox PC running Rocky Linux 9.

Now here’s the weird thing. When I configure a remote connection from Virtual Machine Manager on my workstation to the KVM installation on the sandbox PC, I have some weird glitches and errors.

To setup the remote connection, I use authentication over SSH keys. I’ve already done this quite regularly in the past, but now I get some strange errors.

For example when I choose the Rocky Linux ISO in /var/lib/libvirt/images, the OS isn’t detected automatically anymore, though it works perfectly with a local connection:

And when I try to start the VM, I get the following weird error:

In the past, remote connections with Virtual Machine Manager worked flawlessly. Any idea what’s going on here ?

Is it not the case that VMM was deprecated?

1 Like

Maybe. But that’s not the question here. Please try to stay on topic.

It could well be due to Rocky 9 having newer packages than Rocky 8, and thus the incompatibilities with newer versions of qxl, etc. Most likely you would have more success connecting VMM from Rocky 9 to Rocky 8. At least what I’m guessing right now.

1 Like

I gave this a spin and downgraded the sandbox PC to a minimal Rocky Linux 8 with KVM and libvirt.

Automatic OS recognition still doesn’t work, which is only a minor annoyance, since I can always select Red Hat Enterprise Linux 8.9 manually from the dropdown menu.

On the other hand, everything else works perfectly. No more unknown video cards or similar nonsense. So I can confirm this seems indeed like a version mismatch.

Thanks & cheers !

Niki

This varies, I’ve had similar, and it depends on the ISO images and version. It’s not unique to Rocky, I’ve also seen it with Debian, Ubuntu, etc.

For example, it may be that the packages don’t have up-to-date version info for say the latest, like you found with 8.9. It may however detect 8.8 or lower without problems. I’ve also had ISO’s detected as something else completely…

You could if you wish, do a Fedora 40 install on a VM, and then checkout the libvirt/kvm/virt-manager in there, and you’ll see it will most likely recognise a lot more ISO’s than what you are seeing in Rocky 9 or Rocky 8 - mainly due to newer libvirt packages, etc.

Connecting from newer to older systems will work. Connecting from older systems to newer ones will generally cause errors or weird behaviour like you experienced.

The error does mention ‘qxl’. RHEL 9 does not have QXL and SPICE: 2030592 – Keep QXL/SPICE support for RHEL 9

If something (image for VM?) asks for “qxl device” from hypervisor (libvirt) and/or virt-manager that no longer supports those, then that could explain the error. There were some juggling to migrate VM’s to el9 hosts as VM definitions had to be updated (out with QXL and SPICE, in with VNC and …).

1 Like