Rocky Linux Installation Not working properly in VirtualBox

I have installed RockyLinux 9.3 on VirtualBox 7.0.14 and use it as base image, My Base OS is windows 11.

My installation worked fine, but whenever i create full clone and try to boot it, the full clone image gave error screen but when i build linked clone and try to boot it , the linked clone image worked fine and booted successfully.

I tried with different Linux distro iso (Fedora and ubuntu ) but all worked as expected with both option (viz full clone and linked clone ) .
I’m getting same error with VMware workstation , so i think Rocky Linux 9 image behave differently but i am unable to understand why and how to revert its behaviour like fedora and ubuntu ISO.

Error for your Reference:
Booting ‘Rocky Linux (5.14.0-362.24.1.e19_3.x86_64) 9.3 (Blue Onyx)’
[ 9.054307] systemdLll: Invalid DMI field header.
12.983222] Warning: Unmaintained hardware is detected: el000:100E:8086 @ 00 00:00:03.0 14.803051] vmwgfx 0000:00:02.0: Idrmi ERROR vmwgfx seems to be running on n unsupported hypervisor.
14.803053] vmwgfx 0000:00:02.0: Idrmi ERROR This configuration is likely b oken
[ 14.803055] umwgfx 0000:00:02.0: [drm] ERROR Please switch to a supported g laphics device to avoid problems. You are in emergency mode. After logging in, type “journalctl -xb” to view .ystem logs, “systemctl reboot” to reboot, “systemctl default” or “exit” o boot into default mode. live root password for maintenance (or press Control-D to continue):
Screenshot 2024-03-27 111748