9.2 system update corrupts running Rocky LInux under VirtualBox 7.0.6

I installed a prebuilt VM for Rocky Linux I obtained from Linux VM Images on VirtualBox 7.0.6 running under Windows 7 64-bit. I’ve had Ubuntu running on this setup for a decade without issue, currently 23.04… The RL VM starts up fine and seems fully functional. I can shut it down and restart it without error.

However, if the system detects updates are available, and I allow it to install them, then upon reboot the system appears to be corrupted. Fortunately, I had taken a backup before I updated, so I restored the backup. With that, I can successfully start up Rocky Linux, but if I again allow it to install updates, the system again won’t boot.

When this happens, I see the following messages in the console:

systemd[1]: Invalid DMI field header.
Warning: Unmaintained hardware is detected: e1000:100e:8086 @ 00 00:00:03.0
[drm:vmw_host_printf [vmwgfx]] ERROR Failed to send host log message.
You are in emergency mode. After logging in, type “journalctl -xb” to view
system logs, “systemctl reboot” to reboot, “systemctl default” or “exit”
to boot into default mode.

I tried looking at journalctl. The output is very long, but from what I can see, all the actions appear to be completed successfully. I searched for error and warning; the only error is the one identified above. The only warning is “no autoactivation for /dev/sda2” which seems serious; If I look at “df -k”, I see /boot is on /dev/sda1, so I’m guessing root would be on /dev/sda2. But I see /dev/mapper/rl-root, and all the files normally on root are there, so I believe root is intact.

I’m at a loss as to what to do. I found one article on Gentoo reporting the same error I’m getting:

VirtualBox 7.x - no more VMs

That post seems to conclude the issue is with VirtualBox 7. Has anyone here been able to run Rocky Linux 9 under VirtualBox 7?


These are not official Rocky Linux images, therefore they are not supported by the Rocky team. Official image should be downloaded here: Download Rocky | Rocky Linux

If you look at alternative images, you could download the generic cloud qcow and convert this to a format that VirtualBox supports and use that instead.

Other than that:

Warning: Unmaintained hardware is detected: e1000:100e:8086 @ 00 00:00:03.0

suggests your network card config for the VM. Change it from e1000 to something else if VirtualBox allows this.

You could also download an ISO and install the VirtualBox VM in the normal method of installing a system and see if it behaves the same or not. That will then rule out the problem that the VM image you downloaded is actually the problem, or some VM hardware that Rocky doesn’t like.

1 Like

Thank you for the reply. I switched the network adapter in the VM from “Intel PRO/1000 MT Desktop” to “Paravirtualized network (virtio)”. Upon startup, I did not see the message “Warning: Unmaintained hardware is detected: e1000:”. So, that’s progress.

Unfortunately, when I allowed the OS to update, I ended up in the same place: systemd[1]: Invalid DMI field header and the system non-bootable in emergency mode.

So, I’m changing tactics. I’m downloading the DVD ISO, and will do a normal install. I was hoping to quickpath this, as I just want to test some software in a Redhat environment. I normally run Ubuntu MATE VM, and I want to make sure what I’m working on also works in the Redhat universe.

I’ll report back if I continue to have problems in a native install.

This actually is a VirtualBox 7.x issue, as some users discovered after upgrading their Debian 11 VMs to Debian 12: Debian forums link

I used to rather like VirtualBox when I had to run a Windows client (and when other hypervisors were unavailable), but its QA seems to have gone downhill the past few years, unfortunately.

Me too, at least until Oracle got hold of it. Although I mostly used Xen virtualisation under Linux until that disappeared. Now KVM all the way. Less problems, kernel support by default without compiling extra modules into it like VirtualBox and others.

I installed from the DVD ISO downloaded from the Rocky Linux site, and installed the Workstation variant into VirtualBox. I am still seeing the “systemd[1]: Invalid DMI field header.” upon each boot. I switched to the Paravirtualized Network (virtio-net), which eliminated the “Warning: Unmaintained hardware is detected: e1000” warning.

I’ve done several updates with no corruption (after of course taking a backup in case the updates did corrupt.) So, I suppose the problem is with the images from linuxvmimages.org. I’ll report to them when I have a moment. I don’t think the network adapter was causing an issue, but the paravirtualized adapter is supposedly more efficient so worth the switch.


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.