Issues when running in KVM virtual machine

was Rocky tested in KVM (Proxmox)?
Yesterday I tried to install it in a new VM (minimal install) and quickly noticed 3 issues that don’t occur at CentOS or Oracle Linux of the same version.

  1. Package qemu-guest-agent isn’t automatically installed and the guest agent isn’t therefore running
  2. Repeated occurrences of the following console messages
psmouse serio1: VMMouse at isa0060/serio1/input0 lost sync at byte 1
psmouse serio1: VMMouse at isa0060/serio1/input0 - driver resynced.
  1. After some time the VM became unresponsive with messages such as
Task ... blocked for more than ... seconds

Repeatedly printed to console for various processes and also 1 CPU core being fully utilized (visible from the virtualization infrastructure).

Because I didn’t have time to play with things I simply reinstalled the VM with Oracle Linux and all the issues are gone, it works just fine out of the box. Similarly other CentOS 8 based VMs running alongside this one are fine.

It looks like something was overlooked at this front.

Hi @mag welcome to the RockyLinux community

Until now have not encountered your more serious issues (also had to install the qemu-guest-agent manually)

Which version of pve are you running? (updated mine to 7 recently)
Other notable subjects about the provisioning of the RockyLinux VM on Promox?

Here the pve configuration of one of mine VM's

bios: ovmf
boot: order=scsi0;ide2;net0
cores: 4
efidisk0: raid-lvm:vm-301-disk-1,size=4M
ide2: local:iso/Rocky-8.4-x86_64-minimal.iso,media=cdrom
memory: 4096
name: RL01
net0: virtio=AA:E3:4D:9F:37:2A,bridge=vmbr0,firewall=1
numa: 0
ostype: l26
scsi0: raid-lvm:vm-301-disk-0,size=128G
scsihw: virtio-scsi-pci
smbios1: uuid=84bd12ba-fd90-479f-9e25-b930b87006d7
sockets: 1
vmgenid: 6556dbd7-78a3-4c13-86af-c5a275cd581a

PVE 6.3 in this case.
NUMA off as well
VirtIO SCSI Single with iothread enabled for some (not all) disks

Possibly be a proxmox thing. I installed rocky on my laptop using KVM with virt-manager, and there are no such issues. Also qemu-guest-agent was installed by default, I didn’t have to install it manually.

This can be related to templates being used to create the machine. I did use RHEL 8.2 templates in KVM/virt-manager. I have seen similar issues when using incorrect templates when creating a machine for installing a Linux distro. Hope it helps.

The thing is that OL/CentOS 8.4 don’t have these issues with exactly identical VM config. I just reinstalled it to OL and everything is fine. The same for CentOS.
Hard to imagine how this could be an issue in the Proxmox. More likely something specific is missing in Rocky.
I didn’t even use any template for the VM, just created it from scratch in the Proxmox web console just like few other VMs before.

Strange that the qemu-guest-agent installed for you. Maybe it also depends on the used installation media? I used minimal ISO (and minimal install and later server) and it didn’t install while just cleanly reinstalling with OL did install it.

I also tried to use the repository URL Index of /pub/rocky/8/BaseOS/x86_64/os/ as the installation source, it downloaded metadata etc. but after the installation started it failed to download packages (Packages/grub2-tools-minimal-2.02-99.el8.x86_64.rpm) which was really unexpected.

EDIT: So the issue with grub2-tools-minimal-2.02-99.el8.x86_64.rpm when using the online repository is Server reports Content-Length: 212952 but expected size is 213032 and that’s really the case - sends the 1st value in Content-Length, but the directory listing shows the other one.

Sorry, this is a bit to vague :question:
How do you expect someone (like me) try to reproduce your issue?

Oracle Linux, though build from the same (RHEL) sources, it is really different on key subjects (BTRFS to name one)

I like to suggest that if you expect “something” is missing on the Rocky Linux minimal iso to install RL using the full DVD and select the bare-minimal at the software/package selection.

I used minimal ISO install. The only difference is mine is a Linux distro with an install of kvm with the virt-manager GUI tools for creating the VM’s. I don’t use proxmox, so can’t say what they do differently that would cause this to be an issue. Since both have KVM underneath, then I would have expected it to just work. This is why I hinted at potential VM settings. Are you using latest proxmox?